Hot answers tagged

3

How can I get the script to run even if I didn't previously logoff? A Logon script, by definition, runs at Logon. If you don't log off then the script isn't going to run again. It doesn't run on a disconnect/reconnect to an already logged on session.


1

jochem's answer is more thorough and correct, please reference it. First, create a jetbrains user on your server. Second, assuming you choose to use init.d (System V), do the following: $ touch /etc/init.d/jetbrains-license-server $ chmod +x /etc/init.d/jetbrains-license-server Now place the following contents in this file: #!/bin/bash # Startup ...


1

The anwer of @chris-betti is correct. However for DEBIAN based systems I have three additions: ensure that runlevel 2 the license-server is also started ensure that there is a jetbrains user ensure that the PID file is in the correct location (/opt//logs/license-server.pid) ad 1: see the script file below. You need to change the line # Default Start to ...


1

You can just run the command through sudo like this: sudo -H -u user01 /etc/init.d/script start -H sets the HOME environment variable to that of the user -u specifies the username to run as


1

Open the messages system log tail /var/log/messages you will see an error log telling you the problem and the line number. Looks like this: Sep 21 16:34:28 0 init: /etc/init/uwsgi.conf:9: Unknown stanza


1

This really isn't an answer due to the two limitations noted below but it's too long for a comment, so.. I did a simple test with the following two shortcomings: The scripts do not send email. I need the smtp relay of my ISP but it's too much hassle to find it. I'm testing on a Win10 preview, not a Win8.1. It's all I have this evening. Inside of Local ...


1

Studying and using everyone's comments and answers actually helped resolve my problem, but as sometimes is the case the real issue was somewhat different. So, I feel obligated to post what turned out to be the actual problem for me in case someone else gets caught by the same 'gotcha'. During script testing it seemed more convenient to work on my Win 8.1 ...


1

You have SELinux enabled, and in its default configuration it does not allow web servers to access content in user home directories. To allow the web server to access user files, you need to set the appropriate boolean, httpd_read_user_content: setsebool -P httpd_read_user_content 1


1

Well, it turns out that there was a dependancy required that wasn't installed on the computer I was on. I thought that the DISM command had worked locally but I was using the computer next to it. So what happened? In this example, I was trying to deploy the free app, Fresh Paint to all of the computers. I had downloaded it from the Windows Store using ...



Only top voted, non community-wiki answers of a minimum length are eligible