Tag Info

New answers tagged

0

You are missing the AuthUserFile /dev/null parameter in your Location configuration.


0

I have been following these instructions, however when I make a commit, the command appears to be executing on the client that made the commit, rather than the SVN server. If you did follow the instruction and put the code to the post-commit.cmd then the hook has to be working as expected. I can advise to follow steps from the answer to analyze ...


2

There is no need to dump and load your repository, you can just save your whole SVN dir to tar.gz, something like: tar -cvzf svnbackup.tar.gz /var/svn/repos For that to work, you must offcourse know the location of your repositories. After you move to newer SVN version, just run the: svnadmin upgrade /var/svn/repos and that will take care of SVN ...


0

I had a similar issue and jsse.enableSNIExtension=false didnt solve it. The problem was much simpler: my svn passwort, hat several special character, which apparently were misinterpreden by the browse, I assume. Anyway, changing the passwort to one only with normal letters and numbers, solved the issue


0

I was finally able to get this working by completely removing Trac 0.12 from both the system default python 2.4 site-packages as well as my python2.7. I used pip to remove Trac and svn and yum to remove subversion. At this point I had to build pcre, swig, subversion, and svn-python from source to get it to work. Source files: PCRE SWIG Subversion This ...


1

During the ssh authentication, you may be prompted to add the host to your known_hosts file? You can disable this by adding the command line option: -o StrictHostKeyChecking=no ssh man page extract: ssh automatically maintains and checks a database containing identification for all hosts it has ever been used with. Host keys are stored in ...


1

To sync and delete files, and exclude some files, you can use --delete and --exclude: rsync -rtvu --delete --exclude '*.svn' ~/testing/ -e "ssh -i ./testing.pem" ec2-user@ipgoeshere:/home/ec2-user/testing/


0

It seems to me that this would be a more direct approach: <Location /svn> DAV svn SVNParentPath /home/svn </Location> <Location /svn/svnRepo1> AuthType openid-connect Require claim folders:svnRepo1 </Location> avoiding the need for the Alias directive. But anyway, as for your problem error message Directory index ...


2

The apache config file is only used when you access the repository using http or https. When you're using svn, the connection is handled by svnserve which is an entirely separate program. The documentation for svnserve is available at the SVN book or the man page man svnserve and man svnserve.conf. You can set the root path when you invoke it, like so: ...


0

Authentication can be performed on Apache asuming modules auth_basic, authnz_ldap and authz_svn are enabled. The following configuration works with an OpenLDAP server but should be easyly be made to work with Active Directory. <Location /r> DAV svn SVNParentPath /home/svn/repos AuthzSVNAccessFile ...


1

Note: You have Subversion repository, TortoiseSVN in the name of client only You have (at least) two ways of migration Because physically repository is just subtree on FS, you can move corresponding dir to new location Pure Subversion way: you can svnadmin dump old repo, svnadmin create repo on new location, svnadmin load --force-uuid dump into new ...


1

i solved the access problem giving 777 on www-data:www-data with commands chmod and own on var and var www and all that is below of it (-R),tested with web browser i can explore the repositorys


0

I don't know why, but the apache service (httpd) has stopped. I restarted it (sudo -u root service httpd start) and everything went back to normal.


0

I'm not sure why this worked for me, but I went into the VCS config and changed the SVN Client version from 1.6 to 1.7, and then everything started working.



Top 50 recent answers are included