Hot answers tagged

21

The default connection timeout in IIS7 is 2 minutes. Click on your web site in IIS Mgr, click Advanced Settings, and expand Connection Limits. The Connection Timeout (Seconds) setting is what governs this. If IIS doesn't receive activity on a connection for this duration then it will time the connection out. This is regardless of whether or not the ...


21

I found answer on my posting on nginx forum - http://forum.nginx.org/read.php?2,127854 The answer, in my case, is to set: request_terminate_timeout=30s in php-fpm config. Note, you can use values other than 30s also. I used it to match my value in main php.ini file which is: max_execution_time = 30 Thanks All. :-)


21

fping might be a better tool than the stock ping you are using. What OS are you on? "fping differs from ping in that you can specify any number of targets on the command line, or specify a file containing the lists of targets to ping." "Instead of sending to one target until it times out or replies, fping will send out a ping packet and move on to the ...


18

Sounds like a timeout setting. So your SSMS thinks it takes too long and cancels the connection for you. The SQL server roles back. But there is help. You are not the first person to encounter this. See here. For everybody who doesn't want to click the link. Here is the price winning answer: After hitting the same error, I stumbled upon the corrent ...


17

HA! I finally found the problem myself. It's more related to programming than server admin, but I decided to put the answer here anyway because by searching google I found I'm not the only one with that kind of problem (and since Apache hangs, the first guess is that there's a problem with the server). The issue is not with Apache, but with my Wordpress. ...


15

It looks like the CentOS box's SSHD config is not set to do the client KeepAlive. Drop these two lines in your CentOS sshd config (/etc/ssh/sshd_config), restart it, and enjoy! KeepAlive yes ClientAliveInterval 60 While you're at it, I'd recommend using gnu screen to keep your session alive on the CentOS side.


13

Here how it resolved my issue: make following changes to /etc/nginx/nginx.conf in http { section proxy_connect_timeout 600s; proxy_send_timeout 600s; proxy_read_timeout 600s; fastcgi_send_timeout 600s; fastcgi_read_timeout 600s; and then restart nginx /etc/init.d/nginx restart


11

On Ubuntu the command timeout exists, which is part of coreutils. You can use it like this to set a timeout. Older versions of Debian/Ubuntu didn't build and include this command, but there is a comparable timeout package that you can install. # puppet shouldn't take more then 40 minutes! 47 * * * * root /usr/bin/timeout 2400 /usr/bin/puppet agent ...


9

I was actually unable to reproduce this on: 2011/08/20 20:08:43 [notice] 8925#0: nginx/0.8.53 2011/08/20 20:08:43 [notice] 8925#0: built by gcc 4.1.2 20080704 (Red Hat 4.1.2-48) 2011/08/20 20:08:43 [notice] 8925#0: OS: Linux 2.6.39.1-x86_64-linode19 I set this up in my nginx.conf: proxy_connect_timeout 10; proxy_send_timeout 15; proxy_read_timeout ...


9

For people looking for a solution that involves ping, use the -i switch. ping -i 0.2 www.google.com Or, if you want to use 0.1, you'll need to run it as root sudo ping -i 0.1 www.google.com No need to download extra utilities.


9

Use a Loadbalancer Software with healthcheck like Zen-Loadbalancer or HA-Proxy. There you can configure a healthcheck which pings or open a file on your Webserver and remove them from the Load-Balancing if the file is not available for example. DNS Round-robin is not made for such things because your DNS doesn't know if a server is not available. The DNS ...


8

I would be using nmap for this task. nmap -sP --max-retries=1 --host-timeout=1500ms 10.0.0.1 See the nmap Documentation for more details on this.


8

Yes. Configure SSH to send keepalive packets.


8

The actual answer is almost always that you have a NAT device of some sort in the path, usually a firewall, whose state tables have a fairly aggressive timeout. Because you leave your ssh connection idle for some periods of time, the NAT device "forgets" the mapping between your inside address and source port number, and your ephemeral outside NATted ...


7

I found the cause of this problem. Port 443 was closed in my firewall configuration. It worked sometimes because my IP was added to firewall as a safe one. That's why it did not work for other IPs. All I had to do is open port 443 in firewall and it works just fine :)


7

Maybe it's proxies - proxies are configured in the environment, so might be different for different users, but be consistently set up for those users by their login scripts. I'd suggest env | grep proxy to find out what is set.


6

Generally with any service you will get these sometimes if the server is too busy to respond, hickup in network etc. You might try to see if the server in under load when you get these alerts. I think the main thing you want to look at is the max_check_attempts directive associated with the service or the service's template so you don't get an alert until ...


6

There is a good writeup on this problem here. They recommend: ssh -o TCPKeepAlive=yes or: ssh -o TCPKeepAlive=no -o ServerAliveInterval=15 However, I do have an issue at my work site where I get disconnected from sessions, where at home they are fine. I believe my firewall (SonicWall) may be flucking with TCPKeepAlive, maybe because of NAT. My SSH ...


6

The FAQ answer Q10120906 on the Areca home page talked about a similar problem for ARC-1210. As the suggestion was to "remove battery module to clear the data remain in cache", I unplugged the 2 power cables from the computer and opened up the computer case. There was a small cable connecting the Areca Battery Backup Module to the Areca 1880i card. I ...


6

curl -I will generate a HEAD request. Adding the -L option will make it follow redirects. Timeouts can be controlled with several options depending on which bit of the request you want to time out. From the man page: --connect-timeout <seconds> Maximum time in seconds that you allow the connection to the server to take. This only limits ...


6

You could always try doing 310 minutes instead.


5

Try connection to it remotely with PowerShell. This usually requires less resources then a full fledged RDP-session. Example: invoke-command -computername myServer -scriptblock {Get-Process} This way you can get a look at what's running remotely and later on, kill it.


5

The accepted alternative to port 25 is port 587 as has been recorded in RFC2476 since 1998. You can read all about it if you are into RFCs at http://www.ietf.org/rfc/rfc2476.txt. This is what we have been using for many years to circumvent the ISPs blocks on port 25.


5

These errors mean, that the scripts were running longer than 31 seconds and thus they were terminated, as your fcgid.conf says so. The standard timeout is 40 seconds btw. You can easily check this behaviour by writing a test.php: <?php sleep(32); ?> This should give you an error 500 and put this error in your logs. You have two possibilities to ...


5

After all, I had to do the "research" myself. Here's Chromium (version 12.0.742.112) behavior (running on ubuntu 11.04): Generally it works so: try 1-st ip, once it times-out (after 189 sec.) try 2-nd ip. No error messages given until all ips tried. Next connection will start from first ip again (even if it just failed a second ago and the second ip worked ...


5

Hm, it's possible you did not enable to the correct web extensions which could explain it's intermittent working. I'll link you to this article from technet: technet But the snippet I'd pay attention to is this; IIS6 Dynamic Content: A 404.2 entry in the W3C Extended Log file is recorded when a Web Extension is not enabled. Use the IIS Microsoft ...


5

It is probably a connection rate limit, imposed by the platform's equivalent of iptables. Three connections per minute is the most common setting, which looks suspiciously like what you're seeing.


5

This happens in dual stack IPv4/IPv6 environments where the machine doing a DNS lookup sends requests for AAAA and A records on the same socket, expecting to receive two replies back. This is default behavior for relatively recent versions of glibc. The Juniper firewall, however, drops the connection after the first reply comes back. The Juniper knowledge ...


5

The only way to get more info from haproxy than what you have, would be to use the show sess or show sess <id> command periodically to watch the state of each tcp connection, though I'm not sure if you would get any more useful information. The cD termination state is the most helpful piece of info you have. What it means exactly is that an ...


5

If DNS resolution simply times out and a response never comes back from the DNS server at all, or the return is SERVFAIL, then the message is supposed to be queued and tried again later. If DNS resolution returns NXDOMAIN (the name doesn't exist) then the message is supposed to be returned immediately. See RFC 5321, section 5.1: The lookup first ...



Only top voted, non community-wiki answers of a minimum length are eligible