Tag Info

Hot answers tagged

10

Sendmail: short host name to FQDN via /etc/hosts entry Reorder your /etc/hosts file entries: 127.0.0.1 localhost localhost.localdomain 127.0.1.1 myhost.mydomain.eu myhost.domain2.eu myhost It should qualify myhost to myhost.mydomain.eu (the leftmost name in /etc/hosts line with myhost)


9

No, this won't physically damage your network adapters. You're chasing a red herring. There isn't enough detail here to actually solve your real problem, but this is an answer to the question that you're actually asking.


7

Your job probably contains invalid syntax, which means Upstart will not consider it. Try running the following as a normal user (not as root): init-checkconf /etc/init/rs-comm.conf


6

It depends on how you have your server configured to serve content. If over ssh: git clone user@192.168.100.18:repo/repository.git or if a webserver is providing the content (http or https) https://user@192.168.100.18/repo/repository.git or if available via a file path: git clone file://path/to/repo or if the server is running the git daemon: ...


6

Add a special server for this that only listens on the local host. server { listen 127.0.0.1:80; listen [::1]:80; ... location /nginx_status { stub_status on; access_log off; allow 127.0.0.1; deny all; } }


4

It turned out to be related to this bug in upstart: https://bugs.launchpad.net/upstart/+bug/812870 Because adm was a secondary group it was not being applied to the process, which is broken as f**k and is apparently fixed in a later version. My solution was to add setguid adm to the init file.


3

sudo starts a shell unless you instruct it otherwise. It looks like you actually want to run this script as another user. To do that, try something like this: #!/bin/bash if [ `id -nu` != diy ]; then sudo -u diy $0 # Re-run this script as user diy else # Everything you want to do goes here fi Keep in mind that /etc/sudoers must be set up to allow ...


3

The manual for git-clone says: Git natively supports ssh, git, http, https, ftp, ftps, and rsync protocols Note that SMB is not in the list. When running git on Windows, the //host/path syntax works because the OS supports it natively - SMB remote paths can be used anywhere a local path can be used. That is not the case in unix, where SMB is an alien ...


3

You might have a minor problem with your DNS resolution via /etc/hosts. Since you appended 127.0.0.1 test to /etc/hosts, the DNS resolver has two entries which refer to the same DNS name, test and localhost. Fixing this could go two directions. If you want an alias, add test to the original localhost line, rather than adding a new line. The result ...


2

Your browser is too smart, and thinks that if you enter a single word into the address bar, that you meant to search, rather than browse to a site. Enter in a complete URL instead, for instance: http://test/ or http://test./


2

Check the mongodb.conf file and see what dbpath is set for and then remove the db files.


2

Just google for linux multipath routing, there are plenty of how-to's.


2

The trailing dot makes this a "Fully Qualified Domain Name" or FQDN. This is an absolute reference that fully specifies the entire path of the server in the DNS hierarchy. Think of it as being the equivalent of a full path in Linux/BSD for a filename starting from root or "/". You would use it when you do not want the OS/programs to be able to append the ...


2

Add the following to your ยด/var/ossec/rules/local_rules.xml`. <rule id="100001" level="10"> <if_sid>2502</if_sid> <description>Suppress email from failed login attempts</description> <options>no_email_alert</options> </rule> This way no email is sent from the alert ...


2

veth[1,2,3,4] are still in the global namespace, and thus routed by the kernel. Your vconfig commands are adding vlan interface to the respective veth, which is not what you want. (ip link show should show a veth1.11, etc. (depending on how name_type is set)) I'm not sure what you're trying to accomplish with VLANs. If you want to isolate n1+n3, and ...


1

are you sure you have the right password? otherwise maybe you should try the EC2 support system.


1

You're using an OpenVZ based VPS. As with all container-based virtualization, you are limited to the kernel modules provided by the host. Your options are: Contact the host and request that they make the necessary kernel modules available to you. Use a VPS not based on containers but on full virtualization or paravirtualization, such as Xen, KVM or ...


1

Host on which is hosted your VPS does not provides necessary kernel modules. On CentOS you need to able to load ipt_LOG.ko if you want to use -j LOG in iptables. You could contact your hoster to clarify this moment


1

change it to be: 127.0.0.1 localhost localhost.localdomain 127.0.1.1 myhost.mydomain.eu myhost.domain2.eu myhost


1

What is wrong? change it to be: 127.0.0.1 localhost localhost.localdomain 127.0.1.1 myhost.mydomain.eu myhost.domain2.eu myhost the first from the left i line with hostname o staken to EHLO)


1

This post solved my problem. It was because of the following files: /usr/bin/ssh /usr/sbin/sshd which were preventing aptitude from properly upgrade openssh-server. After following the instructions on the mentioned post, just did: $ sudo aptitude reinstall openssh-server ssh And problem solved!


1

Where and when it is needed? as other mentioned - when you want to have FQDN. Use it in etc/hosts file


1

myhost.mydomain // here it is not FQDN: programs might append local system's domain to end of it but: myhost.mydomain. // here it is FQDN: programs can't append local system's domain to end of it


1

If your port forwarding is set up correctly, you shouldn't need to adjust any settings on Apache. I would revert the change you made to your Apache configuration and re-test. Try running 'tcpdump' on your VM to see if traffic is reaching it from the outside world. If not, I would check your router configuration first.


1

I also posted this question to the Phusion Passenger Google Group: https://groups.google.com/forum/?fromgroups=#!topic/phusion-passenger/V-t5xsHJ4Sw The suggested reason for the installation failure was: Your server probably does not have enough memory to run the compiler. Try increasing your swap space. I then followed this guide to add the ...


1

Okay, two ideas. First, in your Apache config why do you have 3 ProxyPass settings for URLs that all seem to be set to live at /portal/? ProxyPass /portal/api-v1 ajp://127.0.0.1:8009/portal/api-v1 ProxyPassReverse /portal/api-v1 ajp://127.0.0.1:8009/portal/api-v1 ProxyPass /portal/jsp ...


1

Unless you get an answer from someone who has tried this before, a quick bit of Googling seems to suggest that you're playing with fire. While this question on SuperUser suggests that more recent versions of rsync support resource forks, I see no such mention in any of the upstream changelogs. It may be specific to the OS X version of rsync. Tread very ...


1

In your main configuration file which is usually /usr/local/icinga/etc/icinga.cfg you should add a line with no spaces at the beginning: cfg_file=/usr/local/icinga/etc/conf.d/hosts.cfg (you can see it here as well: http://docs.icinga.org/latest/en/configobject.html). It means that you define objects (here hosts) in the file specified above. In that file ...


1

Every time I've encountered errors like that, the easiest solution was replacing the drive. Basically your system crashes because the entire system is waiting for things to be written to disk, the load goes up, and becomes completely unresponsive. It could be an issue with bad sectors, it could be a failing controller, or a bad ATA connector on the MB, ...


1

Bad news! It looks like you have a failing disk or disk controller. Try replace sdd and see if that resolves the issue. It it doesn't - then the issue will likely be your disk controller.



Only top voted, non community-wiki answers of a minimum length are eligible