Tag Info

Hot answers tagged

9

I wouldn't trust that machine anymore, and would reinstall and probably scan for rootkits (some rootkits even survive formatting of a drive). If you care about security, my personal advice would be to restart fresh.


5

Note that 13.04 is no longer supported. Upgrading to a supported version is the recommended action. But if a short term solution is needed, it's possible to rebuild the packages from source (sample instructions) with a patch applied, e.g.: sudo apt-get install build-essential fakeroot dpkg-dev devscripts apt-get source openssl sudo apt-get build-dep openssl ...


3

The nodejs package you installed from the PPA includes npm since v0.10.0. Since you have v0.10.15, when you ran sudo apt-get install nodejs you also installed npm. Try to run npm to confirm. Also see the offical installation guide (the one you followed is a copy of it, but the official one has a few extra details).


3

Your should use sh -x /etc/init.d/haproxy start and this will print debug infomation.And where you got wrong.


2

You missed all or part of the "Configure Package Management" step in their instructions. You need to follow those steps to add the official Mongo apt repository to your system, and then update your local package list. After doing this you should be able to install.


2

Have you restarted nginx to apply changes? sudo service nginx restart Can you try stopping nginx and check that all processes are stopped, before restarting it: sudo service nginx stop ps aux|grep nginx # should display no nginx process sudo service nginx start If you have "[emerg] bind() to 0.0.0.0:80" in logs, check which process is listening to port ...


2

Someone here could tell you you'll be fine but how will they know for sure ? Surely the correct thing to do here is to test the upgrade for each of your server types. You know, for each $ServerType Spin up a new instance configure it as per $ServerType, run your test suite do the upgrade run test suite analyze the results


2

The best option would be to do a graceful restart (service apache2 reload) in order to have the config become active without downtime (the new process takes over the listener while the old process completes any active requests). To automate this you'd need something watching the files then restarting the service.. probably not worth the effort if you're ...


2

~ nmap -p 3306 173.230.131.33 Starting Nmap 6.40 ( http://nmap.org ) at 2014-02-04 20:15 CST Nmap scan report for ftd.fasttrackdispatch.com (173.230.131.33) Host is up (0.044s latency). PORT STATE SERVICE 3306/tcp closed mysql Nmap done: 1 IP address (1 host up) scanned in 0.13 seconds Looks like your MySQL port is closed.


2

Please try zpool list. This will show if the pool is even available to the system. Try to import. Maybe a zpool import -f nestpool Perhaps try to remove the unavailable log devices via: zpool remove nestpool mirror-1 From now on, use whole devices for L2ARC and ZIL... Edit: Your easiest fix is to temporarily create the symbolic links you need in ...


2

I'm not sure if you are having the same issue that I am (I'm running Ubuntu 13.10, and not 13.04), but this worked for myself. Here is the original answer: http://stackoverflow.com/questions/19446679/mcrypt-not-present-after-ubuntu-upgrade-to-13-10 sudo ln -s /etc/php5/conf.d/mcrypt.ini /etc/php5/mods-available sudo php5enmod mcrypt sudo service apache2 ...


2

If you're using sudo and a key I would wager you're not preserving the SSH_AUTH_SOCK environment variable. This will be required in order to establish a connection from the orchestrated machine to the mongodb instance. In this situation you should add something like the following to /etc/sudoers: Defaults env_keep+=SSH_AUTH_SOCK Defaults ...


2

Unfortunately, there's no easy and painless way to upgrade now. You installed from the official sources, and it's definitely easiest to stick with them. General ways to get an updated version are: Wait for the next release. Use the version from backports. Unfortunately, PHP 5.5 is not available on raring-backports yet ...


1

You can get vsftpd to point at another directory by adding/changing the below option to your vsftpd.conf file : local_root=/var/raid/$USER Please be aware that this will also look for the user folder. If you want all users to login to the same directory remove "/$USER"


1

Since you asked for suggestions - We recently faced this problem and if like me you don't want to run a OS which is not supported any more, we decided to switch to Debian all together, this might appear over kill to someone but "to each his own". Whole purpose is not to worry about OS not being supported after every 1 year. Ubuntu 13.10 is supported for 9 ...


1

Sorry i wanted to post this as a comment but dont have enough rep. Anyway i had to do the same and followed these steps, below is the following i did to go back to PHP 5.4 remove your php, apache, etc sudo apt-get purge apache2 php5 libapache2-mod-php5 # add here your server packages change repositories to raring (with backup) sudo sed -i.bak ...


1

The ZFS filesystem daemon is either configurable by passing it right command line arguments or by putting them to the configuration file /etc/zfs/zfsrc. Version 0.7.0 of the daemon brought a new flag enable-xattr which enables support for extended attributes. Put this flag to the configuration file, restart the daemon and it should work. Keep in mind that ...


1

Unfortunately, ssmtp does not read ~/.forward. Here is a quote from the ssmtp manpage: It does not do aliasing, which must be done either in the user agent or on the mailhub. Nor does it honor .forwards, which have to be done on the recieving host. It especially does not deliver to pipelines.


1

DFS Referrals for domain-integrated namespaces happen via Active Directory and leverage Active Directory Sites and Services topology information to function. DFS Namespaces do not function on Windows computers that aren't joined to the domain, nevermind Linux computers. There may be something in the Samba package to deal with this, but I doubt it. You may be ...


1

I haven't tried this myself, but it seems to be what you're looking for : Matt Shay originally posted an identical questions regarding mounting dfs shares in linux (Ubuntu/Linux - Cannot see files in folders when connected to a DFS tree on Windows Server) He solved his own question and put this guide up on connecting to a dfs within Linux. I never ...


1

I did the same test and found it is because ssh command ask for fingerprint confirmation when you first time ssh, therefore ansible stuck and couldn't handle remote prompt. The easy way could be tweak you ssh tunnel command as below: ssh -o UserKnownHostsFile=/dev/null -o StrictHostKeyChecking=no -f -N -L 27018:localhost:27017 mongo@remote-server it ...


1

Should be ok.....just make sure you have appropriate modules compiled and available for all the drivers on the new board.


1

Did you install the development headers? You should be able to get 1.4.4 in the repositories and not have to compile from source. That is what I did although I am not on Ubuntu 13.04. apt-cache search libsrtp should hopefully yield either libsrtp-dev or libsrtp1-dev or something along those lines


1

Make backup of /usr/include/python2.7/pyconfig.h And replace this file with /usr/include/x86_64-linux-gnu/python2.7/pyconfig.h This is temporary method. I think if Distribute package or Ubuntu is updated then this problem will be solved automatically.


1

You're missing a try_files. location / { try_files $uri $uri/ /index.php; # ....everything else } You might also have a problem with the rewrite since you don't have a / at the beginning of the relative URL controllers/$1.php.... Try changing that to /controllers/$1.php.... And, you're missing a fastcgi parameter that tells php-fpm where to find ...


1

EDIT: Generally speaking you should get your default gateway from your DHCP server via Option 003. The best approach would be to configure your DHCP server to correctly provide this information to clients. If you can't do that for whatever reason, I believe you can manually specify it in your /etc/network/interfaces file using the gateway directive (see ...



Only top voted, non community-wiki answers of a minimum length are eligible