Tag Info

New answers tagged

0

I could be wrong, but the error doesn't seem to be related to a version mismatch. Log in to the box and run sudo apt-get update. Log out and see if you can provision with vagrant provision. Sometimes an update doesn't complete properly and just needs to be rerun. If that doesn't work, log in and try sudo apt-get install php-apc=3.1.7-1 to see what the ...


1

Make sure you've updated both Vagrant AND VirtualBox installs. I had a similar issue (and came across this answer) and updating my VirtualBox install fixed it. The problem was caused by having a box installed with newer guest additions than the installed VirtualBox software version. In my case: GuestAdditions versions on your host (4.3.12) and guest ...


0

Your original issue was/is that :datadir needs to be an absolute path. Hiera does not allow you to specify relative paths for the :datadir. If you feel this should be allowed, please submit a request to change it. manifestdir is deprecated. You may prefer to use yamldir instead. You can override that setting when you pass puppet apply. For vagrant: ...


0

I got the error message to go away by putting the following in my provisioning script, prior to any apt-get calls: export DEBIAN_FRONTEND=noninteractive This makes debconf use a frontend that expects no interactive input at all, preventing it from even trying to access stdin.


0

I had the same error message. The problem came from the ssh key that was not owned by me but by the root user. sudo chown {USERNAME} /home/{USERNAME}/.vagrant.d/insecure_private_key Everything works well now!!!


-1

I met the same problem on my Debian box. I discovered that if I exec command "monit reload" after any modification to monitorc file the httpd server can be started correctly. so maybe what you need is just executing "monit reload" every time you have made some change to the configuration files.


1

Perhaps you have the default-000.conf file messing up your virtualhost configuration. Run apache2ctl -S to have the full list of virtualhost enabled on your server.


0

For the configuration you want, you need to have the virtual machine's NIC use your existing bridge br0 on the host. Unfortunately vagrant-libvirt doesn't seem to support this configuration (it only uses macvtap, which is meant to take over a physical interface completely and doesn't help you here because the host cannot use the interface). I would contact ...



Top 50 recent answers are included