Tag Info

Hot answers tagged

2

On debian based distributions, the default virtualhost specifies no ServerName at all, which effectively means it ends up with the systems hostname as its ServerName. Since it's listed first, it's going to cover up any later vhost with that same ServerName. I'd suggest disabling the shipped default virtual host and adding your own that speecifies a ...


2

You have to specify the full hostname when setting the ServerName parameter: ServerName project2.com Since you left off the '.com' apache doesn't know to send you there.


2

In an effort to get a fresh perspective on this problem, I started to configure a similar relayhost setup on another server and it was during that process that I finally traced what the source of the problem. Turns out in my sasl_passwd file I was missing a crucial character. sasl_passwd file before the fix: DomainB.name ...


1

In the default Apache configuration, the AllowEncodedSlashes directive is set to off. This means that: "...The AllowEncodedSlashes directive allows URLs which contain encoded path separators [...] to be used in the path info. With the default value, Off, such URLs are refused with a 404 (Not found) error. ..." So the problem is that mod_proxy is not ...


1

Once you define a first vhost on port *:80, all your port 80 traffic is handled by that vhost as opposed to the base webserver configuration. Usually the best way to proceed is to create two *:80 vhosts. The first one defined is the default will cover everything your base config used to handle -- the second specifies ServerName/ServerAlias to capture the ...


1

If there is no default site config then nginx will auto select the first available config file when presented with a request it doesn't have specifically configured. In this case when you add the www in front of either domain nginx is selecting website1.com config To resolve this particular issue replace the following lines of the configs website1.com ...


1

In ubuntu 14.04, The location of Apache configuration files is under /etc/apache2/ Put those virtual hosts inside the file called /etc/apache2/sites-enabled/default & the reload the configuration.


1

Looks like you just need to load mod_proxy_http.


1

Alias /results /var/www/html/mysvr/results ProxyPass /results ! This excludes /results from being passed to tomcat. The first line is optional if the results folder is in the correct place in the document root. Be sure to include this ProxyPass line before the others to make it work.


1

Looks ok to me, why don't you just try it and see ? If they are all going to be the same you may want to consider using links to a single document so you only have to make changes in one place. Also bear in mind that not all robots will honour a robots.txt file, you may end up having to block them using other means.


1

The simpleSAMLphp installation procedure is documented on the simpleSAMLphp website. It states there that only the www folder has to be available from the internet, which can be achieved by aliassing /simplesaml. It looks like you're doing that. Not knowing anything about your setup, I can not possibly know if you won't break anything by doing this. ...


1

I've just been struggling with this myself. Isn't ePages fun? There a number of ways in which the ePages Apache configuration differs from a more "normal" site. 1. It rewrites most of the config files every time the ePages service restarts. Anything with a "zzz" prefix (which is most of the files in conf.d) will be rewritten, so don't bother editing those ...


1

You've got this set up to listen to *.*.*.[clientdomain].co.uk, not *.[clientdomain].co.uk. *.*.*.[clientdomain].co.uk won't match a.[clientdomain].co.uk, since there aren't enough .s in the host name.



Only top voted, non community-wiki answers of a minimum length are eligible