New answers tagged

-2

You can not achieve true line speed in VPN network unlike through public network because VPN has more hops, more overhead than your public network traffic. Try using UDP for slightly better performance.


0

I took hbogert's script and wrapped it in Applescript for myself and another employee, it's available here: https://www.dropbox.com/s/lh0hsqdesk3i0n7/Execute-Post-VPN-Connection.app.zip?dl=0 Simply connect to VPN, then execute the app and type in your admin password (required for sudo). NOTE: MUST BE SAVED IN /Applications/


2

Yes, if the proxy-server adds a HTTP header X-Forwarded-For, most of them do. Proxy can also add several other headers, depends of the actual software.


2

I just solved this after an hour of fiddling with my Windows 10 settings, and I'm sharing it with you in case it's useful 1) Uninstall SonicWall. Both AppStore and classic apps can coexiste, I've uninstalled both. Reboot your PC 2) From SonicWall's support page, download the 'GVCUtil' cleanup utility. Run it, and remove all configuration files and perform ...


0

The best suggestion I have would be to move your VPN connections from end user PCs to the router/firewall. Both pfSense (free software) and Ubiquiti Edgerouters (inexpensive hardware) allow for this with OpenVPN, IPSec, and other VPN formats, assuming that the VPN provider allows it. Having a real router/firewall is likely to be a good thing for your ...


0

My situation is very similar to the one described by @telemaco. I have some test VMs running on KVM on my laptop computer. My laptop receives its IP address via DHCP, thus the VPN endpoint IP address is assigned by Strongswan to my laptop via leftsourceip=%config. The VMs use a private network 192.168.100.0/24. My laptop (KVM host) receives the IP address ...


-1

Finally I found the problem. adding FORWARD rule to iptables solved my problem.


0

mchen98006: modify the file C:\Program Files (x86)\Cisco Systems\VPN Client\Profiles\mchen.pcf Replace: SendCertChain=1 with SendCertChain=0


0

If IP address 10.248.0.26 belongs to a GKE node, then for doing ping between the GKE node and your remote node you will need to add a firewall rule on 10.248.0.26/24 network to allow incoming traffic to GKE node or all targets in that network from your remote source.


0

You can specify the connection type in the GUI under "Remote Gateway". Setting it to "Dialup User" is what you want. You can also use the "type" option in the phase1-interface table. conf vpn ipsec phase1-interface edit <tunnel> set type dynamic ? static Remote VPN gateway has fixed IP address. dynamic Remote ...


0

You can do this using the wizard or CLI on the Fortigate - configure it on the Fortigate side as a dialup VPN instead of site-to-site.


0

Here are some suggestions that may help debugging the problem: Check if it works if you enclose the path in quotes "\\pbpmwinserver01\server shares" Check that the share it is accessing is "\\pbpmwinserver01\server" (without quotes). If the share paths are fine my next thought would be to validate the VPN (can you ping the server, can you resolve the IP ...


-1

First you need to make sure there is nothing wrong with the shares. Try to access them within your network and make sure they are working the way you want to. Use one of your users account having the problem connecting with VPN to make sure is not a user account relates issue neither. You need to be systematic when troubleshooting problems. If ...


2

As TomTom said in the comments... You want to use a router or acquire multiple IP addresses from your provider. Placing your ILO on the public internet without any protection is also a bad idea.


1

If I edit my security groups to explicitly whitelist my IP, then I can connect, I am more than absolutely sure that the reason for the issue is your security group configuration. If the problem was in your routes, changing security groups haven't made any difference. but that was not the intention of setting up the VPN. Security group is acting ...


0

If you have multiple VPNs you might run into the issue that when they connect in random order, their interface IDs change. In that case the normal ROUTE -P ADD 10.0.0.0 MASK 255.255.0.0 10.0.0.1 IF 42 does not work. The next time the VPN connects it might have a different interface number. Powershell has a cmdlet available that adds routes on VPN connection ...


0

When multiple VPNs connect in random order, their interface IDs change. Therefor the normal ROUTE -P ADD 10.0.0.0 MASK 255.255.0.0 10.0.0.1 IF 42 does not work. The next time the VPN connects it might have a different interface number. Powershell has a cmdlet available that adds routes on VPN connection and removes them again when the VPN is disconnected: ...


0

When multiple VPNs connect in random order, their interface IDs change. Therefor the normal ROUTE -P ADD 10.0.0.0 MASK 255.255.0.0 10.0.0.1 IF 42 does not work. The next time the VPN connects it might have a different interface number. Powershell has a cmdlet available that adds routes on VPN connection and removes them again when the VPN is disconnected: ...


2

Running things via VPN is essentially slower due to the additional network hops and encryption. If you must use a VPN, consider where the VPN is located (latency purposes) and the speed your getting from the connection.


0

I would split your case to 2 separate questions: Network connectivity Yeah sounds doable with openvpn, however keep in mind that you need to have openvpn server somewhere. This will be single point of failure and also potential perf. bottleneck. What I would do: In case I had money to spent : I would contact ISP/DataCenter you're using, and ask for ...


0

This is my Upstart script for PPTP, I think you can fix yours based on mine. You need to replace the [PEER-NAME] with the name of the peer file in the directory /etc/ppp/peers: start on runlevel [2345] stop on runlevel [016] respawn exec /usr/sbin/pppd nodetach persist call [PEER-NAME]


0

Use environment variable LIBPROCESS_IP set binding address. You can set it in /etc/default/marathon or any file that is sourced before starting Marathon service. export LIBPROCESS_IP=10.0.0.1


0

You may try adding the nodefaultroute option in your pptp server's options lists (and also remove defaultroute option), which will prevent the client's to set default gateway to pptp server, when connected. nodefaultroute Disable the defaultroute option. The system administrator who wishes to prevent users from creating default routes with pppd ...


0

Add an iptables rule that will reference your PPTP-server internal interface (facing the LAN) that VPN clients will match. Probably with the VPN IP addresses pool you are using for your PPTP server. In order to reach your LAN SMB servers VPN client's packet will need to cross your VPN server's LAN interface, there you will filter them out.


0

I am using this sshfs options to minimize latency: sshfs -o Ciphers=arcfour,compression=no,nonempty,auto_cache,reconnect,workaround=all user@development.net:/usr/local/gitdev/ ~/dev/code It has the reconnect flag, all sshfs workarounds, using auto cache and arcfour chiper. You can read about those options on sshfs manual, I found those the fastest sshfs ...


0

You could do also this with haproxy. Example config snippet: use_backend server1 if { ssl_fc_sni_reg ^domain1\.com$ } This would proxy traffic to server1 if during the SSL handshake the client used SNI to indicate it was expecting to talk to domain1.com.


0

This is fairly trivial to do on nginx. Define a server for the domain (or each domain), set up locations that tell it what maps to where, and use a proxy_pass to pass the request through to the correct back end server. I believe this is exactly what nginx is designed for. In this case since one is on a subdomain you define two servers and probably only one ...


1

Have you tried ip link set mtu xxx dev tun0 where xxx is whatever you deem appropriate? EDIT: you may want to take a look at this: this guy has a problem similar to yours, I have same problem some time later. My uplink not pass tcp-packets whith= =20 length more then 1496 bytes. I solve this by cleaning DF-bit in all outgo= ing =20 ...


1

1) On 1st PC setup OpenVPN(or any other VNP server) server. 2) On the router connected to the 1st computer, setup port forward or DMZ 3) On 2nd PC setup connection to 1st PC


1

With a VPN. Usually in advanced routers you can setup one, this means both routers in both ends must support it. If both ends have a computer you might leave them switched on, use it as a server and setup Openvpn there. the router then will just NAT the openvpn port to the server and from the server you will have your LAN plugged to your SWITCH who will ...


1

With a VPN. You have tons of options to choose from.


0

Instead of adding each node's pod-CIDR to the VPN config, you could add the entire cluster-CIDR (where any new/recreated nodes will have their pod-CIDRs pulled from). To find the cluster-cidr: gcloud container clusters describe your-cluster | grep clusterIpv4Cidr


0

After a bunch more looking around, pinging different things, and a post on the Cisco forums, the final issue was a bug in the ASA 5512-X firmware version 9.1(3). With my configuration, the ASA was not responding to any pings which were to large or to any packets at all which were to large to be forwarded over the VPN. The temporary solution was reducing the ...


3

Start your Hyper-V machine. Ensure the "Enhanced Session" is disabled/unchecked via the hyper-v top window menu (View -> Enhanced Session). Initiate and connect to your Cisco VPN client session. Once your Cisco session is connected, check to re-enable the "Enhanced Session" menu choice again. The enhanced cut-n-paste should work at this point. Note: After ...


3

Without more detail about what solutions you are using, it will be hard to answer your question precisely, but generically yes you can do that. Usually your VPN server and your SSH server point to some external authentication directory and communicate with it over Radius so you can use the same one for both. In most cases I've seen however, VPN ...


0

It seems like the iptables input table rules do not allow ESP packets. You could try adding "iptables -A INPUT -p esp -j ACCEPT" to iptables.


0

Even though this might be a bit late, you may try what I did: remove all mss, mtu, etc related options do a port scan at your institution and selected a UDP port, generally 53 GRE /123 NDP ports should be open: Add these lines to your server config (ref here) #possible bandwidth increase sndbuf 393216 rcvbuf 393216 push "sndbuf 393216" push "rcvbuf ...


0

I am network engineer. For first: you need to check all ports in your firewall and add GRE (47) port. By default my advice: open both TCP and UDP port. Second: turn off "Secure connection" in VPN connection settings. Try allow all methods: PAP, CHAP, MSCHAP + v2.. I know it's not secure but for some reason ISP can block it. (In Israel I see it very often), ...


1

I've written about it a few days ago. Basically, you need to install the Azure VPN Client and launch it through powershell scripting. This script can be executed automatically by Windows Task Scheduler. Here's my post about it, but although I made modifications, It's based on the two links @LMFAO_A_JOKE sent you before.


0

Yes, an it is easy. Run as administrator CMD route add -p 192.0.0.10/32 172.21.0.1 route add -p 192.0.0.15/32 172.21.0.2 Now all traffic for 192.0.0.10 goes through 172.21.0.1 and for 192.0.0.15 goes through 172.21.0.2


0

CrayFishUK, my experience for all Windows XP/Vista/7/2008/8/2012/10 This will connect VPN as a SYSTEM user when system starts. You will need to create a VPN connection Save or not save credential it is not important. Find a rasphone.pbk in %APPDATA%\Microsoft\Network\Connections\Pbk_hiddenPbk More nice if you will copy it to ...


0

Benny! I tried to rename VPN on Windows 7 using cmd,netsh,wmic and powershell and only one easy way that I have found was this way. By default VPN is a INI file with extension .PBK and it located at C:\ProgramData\Microsoft\Network\Connections\Pbk So you can rename it using BAT file or CMD powershell -Command "(gc ...


0

auto=ondemand means "trigger when there is a need for the tunnel based on a packet". So it will load and wait on the first packet, then bring up the tunnel. If you only want to bring it up manually, use auto=add. If you want to have it always on, use auto=start


1

After some help from @bleve and @LetoTo in the IRC #swan I changed the config like this: left={local_ip} leftid={elastic_ip} leftsourceip={elastic_ip} leftsubnet={elastic_ip}/32 And now works. This line was added to the routing table after connecting the VPN: 192.168.253.155 dev eth0 scope link src 52.6.108.86


0

It seems that the return path for the packets is not known. To be sure you would need to check intermediate routes, I'll get to that in the end. When you ping 10.10.3.50 from the 10.10.2.0/24 host it is forwarded your default gateway (lets assume 10.10.2.1), then itself checks its own routing table and sees the route for 10.10.3.0/24 via 10.10.1.5. A ICMP ...


0

If you are using Windows Open network connections Open settings of VPN connection Go to Networking TAB Go to TCP/IP - Settings In Advanced disable: Use default gateway on remote network.


0

The normal way would be to set up a site-to-site VPN to the remote network. You would set up an instance running a site-to-site VPN like one of these: https://aws.amazon.com/marketplace/search/results/ref=brs_navgno_search_box?page=1&searchTerms=vpn I think the Sophos is great and it supports a bunch of VPN protocols. If your instance connected to ...



Top 50 recent answers are included