Tag Info

New answers tagged

1

Try adding the root and index lines outside the "location" block: ... access_log /var/log/nginx/access.log; root /data/www; index test.html; location / { ...


0

There seems to be a bunch of people who have come accross this issue after the last update. I found my answer here: on the Dav on directories, disable the Directory index features with the following directive: DirectoryIndex disabled Of note: one of the websites I manage was defaced on January 7th through an "Hmei7" php attack on old copies of wordpress ...


0

From Apache 2.4 on, mpm-itk has the AssignUserIDExpr and AssignGroupIDExpr directives, which allows an Apache expression to be used in dynamically defining a user and group. In combination with mod-rewrite it will probably do what you want. http://mpm-itk.sesse.net/


0

As far as I know, ServerName directive does not allow an IPv6 address. It won't accept the brackets nor the colon character of an IPv6 address. That format is only valid for Listen, NameVirtualHost and VirtualHost directives. Depending on your configuration (ie: if you server multiple domains on the same Apache installation) you could try the following. ...


0

First, '[' and ']' are not valid for DNS naming convention, that must be fulfilled in ServerName value. Second, ':' is not valid too - so try to use it without that symbols or use a hostname - second way is better.


0

Quote from http://forum.nginx.org/read.php?2,233709,233722#msg-233722 The server will be able to track the number of connections for ~16k distinct client IP addresses. If you happen to have that many active clients, then the next connection attempt from the client whose IP is not yet known will attempt to create a new state, that will fail ...


0

You say that a browser can't resolve a URL like http://test.example.com. So is test.example.com a registered hostname in DNS? If not, then your RewriteRule will never get a chance to fire because a client won't be able to find it. If you're not sure if test.example.com is registered in DNS, try using any online DNS lookup tool, or from the command line ...


0

IE9 does not show the Content-Encoding: gzip header even though the request is gzip-compressed, so don't trust MSIE when checking whether gzip compression is enabled. And also, beware of MSIE + TLS + gzip + chunked transfer encoding combination, there are some bugs like: https://support.microsoft.com/kb/871205


2

Answer updated thanks to Tero Kilkanen observation I believe the issue is caused by the server_name you have specified. Upon looking at the Nginx documentation (http://nginx.org/en/docs/http/server_names.html) the server_name needs to be in 1 of the following formats: exact name longest wildcard name starting with an asterisk, e.g. “*.example.org” longest ...


2

you already have: include /etc/nginx/sites-enabled/*; which means your servers are included from there (by default symlinked from /etc/nginx/sites-available/) http://nginx.org/en/docs/http/ngx_http_core_module.html#server


1

There is a server directive outside of the http section, this needs to be nested within http rather than as a seperate section. Ideally any server apart from the default should be set-up in /etc/nginx/conf.d/$sitename.conf.


0

splunkd provides the Splunk web interface, since version 6.2. It appears to be proprietary, and no information about its internal workings is freely available. New for version 6.2, splunkd also provides the Splunk Web user interface. It allows users to search and navigate data stored by Splunk servers and to manage your Splunk deployment through a Web ...



Top 50 recent answers are included