Tag Info

Hot answers tagged

2

Since it's only Layer 7; just install something such as DDOS Deflate or null route the IP Range. To null route the IP: route add -host 222.186.129.X reject ip route get 222.186.129.x Output RTNETLINK answers: Network is unreachable To null route the whole subnet: route add -net 222.186.0/24 gw 127.0.0.1 lo Or to install DDOS Deflate: wget ...


2

Since you do not have any addition plugins, I still suggest you to follow below steps: Disable both plugins Switched to default WordPress themes Scan all contents using virus scanner Then try to update contents. If it is still consuming lots of memory, it may be server configuration issue.


2

The memory leak (or just high memory usage) is almost always because of Wordpress. Wordpress is a well known memory and CPU hog, especially if you are using bad plugins and templates. You may try to disable all the plugins and templates one by one until you find which one is causing the high memory usage and replace it with another similar one or report ...


2

It looks like an infinite loop as line 159 of wp-admin/includes/file.php is a recursive call to the function wp_tmpnam(). It breaks the update process, so may be it could be worth checking this small correction, which describes your problem : wordpress bug fix


1

There is no way to do that. PHP is run by PHP-FPM process, which runs as a specific user. The files created are owned by that user. Only the superuser can change the owner of the file, and it is not safe to run PHP-FPM process with the superuser privileges. Your only option of changing the ownership status of files uploaded by the process, is to change the ...


1

As Tero has suggested, you would need to change the user of your php-fpm process responsible for hosting the site you'd like to affect. PHP-FPM has "pools" and I think most administrators will typically have one pool per site hosted. So, if you're hosting example.com and another-example.com, you could have two php-fpm pools that each run their respective ...


1

Try adding this to your httpd.conf or an .htaccess SetEnvIfNoCase X-FORWARDED-PROTO "^https$" HTTPS When using the load balancer + HTTPS, your webserver is unaware that HTTPS is being used on the front end, so keeps trying to redirect to the HTTPS site, when in fact, HTTPS is already being used. The above will translate the header that Amazon's Load ...


1

change ownership to www-data:www-data sudo chown www-data:www-data /path/to/wp -R add your deploy user to the www-data group sudo usermod -a -G www-data deploy


1

Things to check: Is mod_rewrite enabled? (sudo a2enmod rewrite) Does it work outside the IfModule block? Simply remove the lines and see if that changes things. I suspect the first option will fix your problem.


1

Now we know your htaccess damage is, weirdly, intentional, here some suggestions towards a true solution: Your webserver is badly configured and causes many many error log writes. This in itself causes unnecessary IO disk writes and should be fixed. Fix all those errors (Especially around SSL) and your server will already be more capable. Or suppress error ...



Only top voted, non community-wiki answers of a minimum length are eligible