Hot answers tagged

22

I ended up removing the "XkbOptions" line from my xorg.conf, and adding this to Xfce's autostart: /usr/bin/setxkbmap -option "ctrl:nocaps" It turns the caps lock key into an additional Ctrl, which does the trick for me. If you wanted a straight swap, I believe "ctrl:swapcaps" would work. For what it's worth, this page is a fairly decent guide: ...


17

Here (Red Hat Login required) is a Tech Brief article from a fellow Red Hat consultant which discusses the minimum packages needed for X-Windows to work for SSH connections. The key points are: 1) Install the following: xorg-x11-xauth xorg-x11-fonts-* xorg-x11-utils 2) Enable the following in the sshd_config file X11Forwarding yes 3) Use an appropriate ...


12

There are several ways to do this, the one I prefer is to forward the ssh port: First, connect to machine B and forward [localPort] to C:22 through B A$ ssh -L [localPort]:C:22 B Next, connect to C from A through this newly-created tunnel using [localPort], forwarding X11 A$ ssh -X -p [localPort] localhost Now we can run X11 programs on C and have ...


12

The ssh sessions started after I changed the Mac client's /etc/ssh_config to include the line: ForwardX11Timeout 596h are all working fine and have been all day. By now they all would have been refusing to start new xterms. So I believe this is the answer, and luckily a simple solution, but the timeout will still happen 3-1/2 weeks from now.


12

Found the cause, my ~/.ssh/config was incomplete, you need both: Host * ForwardAgent yes ForwardX11 yes My mistake was that I included only the ForwardX11 option.


11

http://en.wikipedia.org/wiki/Xpra sounds more like what you want to do than VNC..


11

Per dbus-launch(1): If DBUS_SESSION_BUS_ADDRESS is not set for a process that tries to use D-Bus, by default the process will attempt to invoke dbus-launch with the --autolaunch option to start up a new session bus or find the existing bus address on the X display or in a file in ~/.dbus/session-bus/ Whenever an autolaunch occurs, the application ...


10

The reason ssh X forwarding wasn't working was because I have a /etc/ssh/sshrc config file. The end of the sshd(8) man page states: If ~/.ssh/rc exists, runs it; else if /etc/ssh/sshrc exists, runs it; otherwise runs xauth So I add the following commands to /etc/ssh/sshrc (also from the sshd man page) on the server side: if read proto cookie ...


9

It's right there in the last line: debug1: Remote: No xauth program; cannot forward with spoofing. In addition to gedit, you'll also need to install an xauth package. If the Ubuntu server wasn't installed with an X Windows system (probable considering you had to manually install Gedit) this is clearly not present.


8

To enable X11 forwarding on the server you need at least the xauth program. Install xbase-clients on the server (or the package that contains xauth) Connect to the server with SSH using the following command ssh -X servername Run the program


7

You can remove groups with yum. yum groupremove "X Window System" "GNOME Desktop Environment" Use yum grouplist to see what groups you have installed.


6

You can try with the xset command : if [[ ! $(xset -q) ]]; then # the X server is not reachable else # the X server is reachable fi


6

Alternatively, if you do not want to use sudo to figure out what the current tty is, you can use Linux-specific sysfs entry: $ cat /sys/class/tty/tty0/active tty8


6

Installed this package: xorg-x11-xauth Got solution from here. Thanks for your help!


5

This will depend on whether your graphics card driver supports it (if you advise what card you have then we can confirm this) but. xrandr --output <output> --rotate <direction> should do it. Check out man xrandr here is excerpt from the EXAMPLES section Sets an output called LVDS to its preferred mode, and on its right put an output ...


5

This can easily be accomplished using port forwarding: A$ ssh -NL 2022:C:22 B & A$ ssh -X -p 2022 localhost C$ xclock Port localhost:2022 is forwarded to C:22 via B SSH to C via localhost:2022 Use X as normal


5

Uncomment the below in /etc/ssh/ssh_config on both machines. ForwardX11 yes ForwardX11Trusted no


5

Based on information found in this page about enabling XDCMP and the file /etc/gdm/gdm.schemas, I managed to create the following file: # /etc/gdm/custom.conf [xdmcp] [chooser] [security] DisallowTCP=false [debug] I also changed the /etc/X11/xinit/xserverrc file to: exec /usr/bin/X11/X i.e. I removed the -nolisten tcp options to the X executable. I ...


5

One option would be to set up X forwarding over ssh and run an X server on your local machine with the apps running on the server. A tutorial Enabling X11 forwarding in SSH HowTo Using XMing and PuTTY in Windows


5

Solved it. NX client seems to assign it's own shortcuts - but only on Ubuntu 10.10 does it assign minimize all windows to the 'd' character. Change it server side when logged in via the NX Client and the problem is fixed. Under Settings > Key Mappings > Minimize All Windows. It won't let you disable it, so just choose a key combo you'll never use (I chose ...


4

Also, check that X11Forwarding is set to yes in /etc/ssh/sshd_config (it is apparently the default in Debian).


4

These instructions should work, but I've just spent the last hour and haven't got it to work yet. Also, you may want the latest version of X11 for Mac, XQuartz. edit XQuartz 2.3.3.2 (xorg-server 1.4.2-apple42), has, under Preferences, a Security tab, with an option called "Allow connections from network clients". I suspect that this setting will make ...


4

VNC will do this for you. It's the Unix version of remote desktop.


4

someapp --display <display identifier> or DISPLAY=<display identifier> someapp The display identifier is usually :0.


4

I suppose the shell TERMs it when it exits, which would be immediately, due to the '&'. Maybe you want to use start-stop-daemon? E.g: start-stop-daemon --start -b -x /usr/bin/Xvfb :1 I suppose if you want the help of the startx wrapper, you may want to run your shellscript instead.


4

You can use my init script. It's based on /etc/init.d/skeleton and seems to work well: #! /bin/sh ### BEGIN INIT INFO # Provides: Xvfb # Required-Start: $remote_fs $syslog # Required-Stop: $remote_fs $syslog # Default-Start: 2 3 4 5 # Default-Stop: 0 1 6 # Short-Description: Start Xvfb. # Description: Start the X virtual ...


4

Actually, if I understand your need correctly you can just skip TCP altogether. Xvfb :0 -nolisten tcp Afterwards this works: DISPLAY=:0 xterm And you can check yourself with netstat -ntlp | grep Xvfb that Xvfb has no ports open.


4

fgconsole is what you are looking for http://linux.die.net/man/1/fgconsole


4

Short answer, No, X is a brain dead protocol. Why X isn't dead by now is astonishing. (I had high hopes for display postscript but that went nowhere...). In X-windows the "Server" is your Mac. The client is the application you are running. X tells your Mac what to render and the Mac does all the work on drawing the screen. At best it's possible that ...


4

Not easily. As of OpenSSH 5.1 the ~C escape commandline supports runtime creation of dynamic (-D) port forwards. If your local X server is listening on a TCP socket you could create a port forward to it. Nowadays most X servers don't. Supposing it is, though, you'd then need to set up the xauth data and set the DISPLAY environment variable. Internally, ...



Only top voted, non community-wiki answers of a minimum length are eligible