Tag Info

New answers tagged

0

Finally I identified the issue. The mirror which is contacted by my machine is not containing the files requested. So changing the base URL/Mirror list in the repository configuration is solved the issue.


1

Add a full release version number (e.g., '5') to the file '/etc/yum/vars/releasever'. You will likely need to create the directory '/etc/yum/vars/' as well. Doing so obviates the need to directly edit any repo files, and your customized value persists through package and OS upgrades; just remember to change the value appropriately (if you upgrade to a new OS ...


2

If you get a 404 in your browser, what does it mean? It's the same thing here. You have cached metadata about this repository that is no longer valid, or you have a network problem reaching the mirror. Start with a yum clean all and try again. If it still fails, start investigating the network stack. (Are you caching a bad DNS record on this host for ...


0

Here is the script I came up with for the brute-force approach #1: #!/bin/bash filelist1='at-spi-registryd.desktop bluetooth-applet.desktop gdu-notification-daemon.desktop gnome-at-session.desktop gnome-keyring-daemon.desktop gnome-screensaver.desktop gnome-user-share.desktop gnome-volume-control-applet.desktop gpk-update-icon.desktop nm-applet.desktop ...


1

The best way to achieve this is to find a repository which has a CentOS 6.5-specific repository, and alter your configs in /etc/yum.repos.d/* to specifically use this repo (essentially hard-coding the values for the base arch and release version). It is worth noting, however, that point releases which are not current are not officially supported (old major ...


1

What you want does not exist. Old point releases are not supported so there are no latest packages to pull. Think of them more as a point in time snapshot of the latest packages for a given release (4.x, 5.x, 6.x, 7.x etc). The FAQ entry for What is the versioning/release scheme of CentOS and how does it compare to the upstream vendor? provides an ...


4

You need to have yum version 3.2.26 or above and if you don't have it install yum-utils package which comes with the yumdb script. Using yumdb you can set a certain package to be kept from being removed on updates. yum update yum yum install yum-utils yumdb set installonly keep kernel-2.6.32-279.2.1.el6.x86_64


2

The packages you try to update seems to be different as per the output.. web2 shows mod-pagespeed-beta where as web shows mod-pagespeed-stable. Make sure you are updating the correct package. Instead you can try "yum update mod-pagespeed-stable".


3

The different servers are using different CentOS mirrors, one of which may not (yet) be completely in sync with upstream. Your yum repository configuration by default uses the mirrorlist=http://mirrorlist.centos.org/... directive, which non-deterministically determines a good mirror. Another server can and will often use an alternate mirror. You can ...


0

Looking at the RPM, it should drop a file in /etc/yum.repos.d called remi.repo:- $ rpm -qlp remi-release-5.rpm /etc/pki/rpm-gpg/RPM-GPG-KEY-remi /etc/yum.repos.d/remi.repo If it's not there, and you're sure the RPM is installed, you should be able to remove the RPM with rpm -e remi-release. Some useful commands for you:- rpm -ql remi-release - will ...


0

rpm -qa | grep remi-release will tell you if the rpm is installed. rpm -e remi-release will remove the rpm. yum repolist will show you what repos are available. yum repoinfo will return more information about the available repos along with their associated .repo file names.


0

"Will be updated" means you already have the package installed. If you want to not have it download both versions, uninstall the one that you don't want. Don't want GCC 64-bit? Use yum remove gcc.x86_64.


1

Include .i686 along with the package name to install the 32bit package. To install the 64bit package you would use .x86_64. yum install gcc.i686


2

It seems like you have nothing in /mnt/cdrom/ directory. Thats why Yum gives you the following error: No such file or directory


1

You need to install the EPEL 6 epel-release package, not the EPEL 7 package.



Top 50 recent answers are included