186 reputation
1110
bio website
location
age
visits member for 2 years, 2 months
seen yesterday

web programming-javascript, php, mysql, css, html-is my thang


Jul
22
comment How to not redirect if requesting server_name only
hmm, if I don't have a listen 80 server block then the first page load of mysite.com fails and with the second load then it accepts it. I only have a listen 443 server block containing your Strict-Transport-Security directive.
Jul
22
comment How to not redirect if requesting server_name only
ok i'll try that thanks
Jul
22
comment How to not redirect if requesting server_name only
hmm i don't have a ssl.conf file, can I put this in my nginx.conf file? If so, in what block? If not, how would I make my server recognize this newly created ssl.conf file?
Jul
22
comment How to not redirect if requesting server_name only
thanks, this is more what I was looking for, trying it out now to see if it does what i need
Jul
22
comment How to not redirect if requesting server_name only
I assume deny all still gives you a blank screen even if there is no error? I guess my question is is there any way to still show the site without a redirect?
Jul
22
comment How to not redirect if requesting server_name only
ok thanks, "connection refused" isn't ideal for a consumer facing site.
Jul
22
comment How to not redirect if requesting server_name only
so if you listen on 443 only and type in only the server_name you get a blank screen?
Jul
22
comment How to not redirect if requesting server_name only
@NathanC thanks, may I ask what the deny code would look like?
Jul
22
asked How to not redirect if requesting server_name only
May
7
awarded  Notable Question
Mar
20
awarded  Popular Question
Mar
11
comment Map a url to a subdomain (NGINX)
@mgovern thanks, my /etc/nginx/sites-enabled is empty so I'm pretty sure my nginx.conf is the only thing that is contributing. Would mind taking a look at the nginx.conf file i included as a gist? gist.github.com/tim-peterson/5136554
Mar
11
comment Map a url to a subdomain (NGINX)
hmm, medicine.example.com redirects to example.com regardless of whether I put your rewrite condition in. So it looks like I have a problem somewhere else in my nginx.conf. Here's my full nginx.conf if that's helpful. Also, is proxy request the same as internal rewrite?
Mar
11
comment Map a url to a subdomain (NGINX)
hi @mgorven, im looking for an internal rewrite, I want to keep the subdomain as the URL, yes example.com is also served by the same web server
Mar
11
asked Map a url to a subdomain (NGINX)
Sep
12
comment How to stop nginx on Mac OS X
using nginx -s stop worked for me but then i wasn't able to restart my server using either nginx -s reopen, nginx -s reload, nginx -s start or nginx -s restart ? How to restart? Nevermind, just executing the program $ sudo /usr/local/sbin/nginx restarts it.
Aug
30
comment Nginx config rewriting subdomain name to 1st URI segment
thanks, problem solved, ugh must have been brain dead!
Aug
30
accepted Nginx config rewriting subdomain name to 1st URI segment
Aug
29
asked Nginx config rewriting subdomain name to 1st URI segment
Aug
28
comment Nginx rewrite to eliminate “www” not working
I have 2 include statements in my http{} block that were there by default: include /etc/nginx/conf.d/*.conf; include /etc/nginx/sites-enabled/*;. Should I comment these out?