710 reputation
2712
bio website blog.chomperstomp.com
location Indianapolis, IN
age 30
visits member for 5 years, 5 months
seen Feb 7 '13 at 16:47

Front-End Engineer at Exact Target

Co-Author of HTML, XHTML and CSS All-in-one Desk Reference for Dummies

Graduated from IU with a Bachelors of Media Arts and Science and a Certificate in Applied Computer Science.

Tech Editor for Building Facebook Applications for Dummies and Building Websites All-in-one for Dummies 2nd Edition.

Creator and maintainer of the Status-bar Calculator Firefox and Chrome extensions

Three years professional experience in Java E-Commerce Development and four years professional experience with PHP

Teach Server Side Programming with PHP and Mobile Applications Development at IUPUI


Aug
11
comment using su inside of a shell script
This is actually what I ended up doing...
Jul
16
comment using su inside of a shell script
I can't get the su - -c "command" to work. How would I supply the password for su?
Feb
15
comment HOSTS file being ignored
Yes, actually, I found out there is a corporate proxy that is intercepting my requests and responding to them. Somehow it was bypassing my hosts file. If there was an entry in the corporate proxy it was overriding my local hosts file entry. While this answer didn't really tell "how" to fix the problem, it did identify the actual root cause of the problem (it's not the firewall...)
Aug
7
comment HOSTS file being ignored
1: Reply from 172.17.1.107: bytes=32 time<1ms TTL=63 2: Nope, reviewed entire hosts file scroll-bar and all... 3: DataBasePath, Type="REG_EXPAND_SZ", Data="%SystemRoot%\System32\drivers\etc" That %SystemRoot% part got me curious, so I opened up my "Environment Variables" and looked for a SystemRoot variable. Didn't see one, so I created one and set it to C:\Windows, then I did an ipconfig /flushdns and pinged www.wiki.com, but it still responded from 70.35.23.23 instead of 172.17.1.107 (which is what I set it to in my hosts file). Thanks though! Good suggestions all!
Aug
6
comment HOSTS file being ignored
and it still didn't work btw
Aug
6
comment HOSTS file being ignored
oops :P Ok, did an nbtstat -R and nbtstat -RR and nbtstat -r and then nbtstat -c (and it said "no names in cache)
Aug
6
comment HOSTS file being ignored
when I issue the "nbstat" command, I get "'nbstat' is not recognized as an internal or external command, operable program or batch file"
Aug
6
comment HOSTS file being ignored
Yeah, everything in lmhosts.sam is commented out and there's only the two lines I specified in the original question in my hosts file...
Aug
6
comment HOSTS file being ignored
And now I either installed BIND wrong, or my computer is ignoring that too, because it isn't working either...
Aug
6
comment HOSTS file being ignored
What should the permissions be (right now the file is not read only and all permissions are set to allow for all users)? I tried setting to www.wiki.com and it still didn't work. (I changed the line to 172.17.1.107 www.wiki.com) Then I opened up my command prompt and tried pinging www.wiki.com and it returned "Pinging www.wiki.com [70.35.23.23] with 32 bytes of data" but then it said "Request timed out" three times. Then anything I tried to ping returned Request timed out. I'm in the middle of a BIND install now to try and fix this, I don't know if that would effect the pings...