155 reputation
8
bio website
location
age
visits member for 2 years, 7 months
seen Dec 23 at 22:29

Nov
24
awarded  Caucus
Apr
17
awarded  Popular Question
Sep
29
awarded  Popular Question
Feb
6
comment strongSwan without password on iOS
I'm suggesting mainly that you configure the iOS client with the certificat and password credentials (from what I can see i don't see many options that disable some other form authentication in addition to having the certificate.) setting the password and username for xauth for example if the iOS device is an iphone should be sufficient to prevent having the user authenticate each time they enable the vpn. The links are mainly there as a references
Feb
6
revised strongSwan without password on iOS
found another email thread for iOS devices
Feb
6
revised strongSwan without password on iOS
Added another link to a thread that may help
Feb
6
answered strongSwan without password on iOS
Nov
2
comment IPsec tunnel to Android device not created even though there is an IKE SA
Thanks all seems to be working now
Nov
2
accepted IPsec tunnel to Android device not created even though there is an IKE SA
Nov
1
comment IPsec tunnel to Android device not created even though there is an IKE SA
Samsung Galaxy Nexus running Android 4.1.2. The Vpn settings are as follows: Type = IPSec Xauth RSA, Server: 96.244.142.28, IPsec clientCert, Ipsec CA Cert= don't verify, Ipsec Server cert= received from server. I didn't specify a forwarding route, dns server,or search domains
Nov
1
comment IPsec tunnel to Android device not created even though there is an IKE SA
I used setkey to create an spd policy and now i can ping the gate way from the device using the internal ip 10.0.0.2 and i can ping the device from the gateway using the same ip. Is strongswan expecting a response from the client before it can complete the negotiation of the IPSec SA?
Nov
1
comment IPsec tunnel to Android device not created even though there is an IKE SA
I added the output from tcp dump on both machines had to cut down some of the information in the xfrm output and remove the long string of nat keep alive messages that tcpdump captured. tcpdump at least shows the communication that happens I guess up until the mode config response is sent to the device. It doesn't look like the device sends anything after it gets the mode config ip. After the last encrypted hash message the device receives the next few message were all nat keep alive messages.
Nov
1
revised IPsec tunnel to Android device not created even though there is an IKE SA
Added tcp dump
Oct
31
comment IPsec tunnel to Android device not created even though there is an IKE SA
The logging is set to level 2 I had to cut out parts because of the body length limit sorry about that. Thanks ill run tcpdump and update once I have some feedback
Oct
31
comment IPsec tunnel to Android device not created even though there is an IKE SA
I posted the log from charon. I had to trim it down so it would fit. That was all the information that was logged when I connected with the android device. I didn't mention in the question but I am using the stock android vpn client.
Oct
31
revised IPsec tunnel to Android device not created even though there is an IKE SA
server logs for charon
Oct
31
awarded  Editor
Oct
31
revised IPsec tunnel to Android device not created even though there is an IKE SA
Added output from ip xfrm
Oct
31
asked IPsec tunnel to Android device not created even though there is an IKE SA
Sep
27
answered Issue in setting up VPN connection (IKEv1) using android (ICS vpn client) with Strongswan 4.5.0 server