85,335 reputation
14116260
bio website serverfault.com
location Manchester, NH
age 40
visits member for 2 years, 9 months
seen 1 hour ago

Moderator at Server Fault.

Contract system administrator since time out of mind. I can also read your code!

If your DevOps is all Dev and no Ops, and you need help, contact me.


Sep
3
answered Nginx CSS Caching
Sep
3
comment Percona slave crashes with “unexpected PLT reloc type”
Do you have a good reason for being out of date?
Sep
2
reviewed Looks OK ssh: connect to host port 22: Connection refused -> AWS
Sep
2
reviewed No Action Needed Slow Network Discovery
Sep
2
reviewed Reopen Is there research material on NTP accuracy available?
Sep
2
comment Installing SCVMM on a VM and use it to manage the hypervisor hosting that VM (for a lab)
Why would this be a problem?
Sep
2
comment nginx Subdirectory Rewrites for MVC
You should have been receiving the entire URL before; this really is something the app should be handling in the front controller.
Sep
2
answered How can you install puppet on CentOS 7
Sep
2
comment How can you install puppet on CentOS 7
Better clear your caches, then. yum clean all
Sep
2
comment nginx Subdirectory Rewrites for MVC
nginx is nice, but you'll have to unlearn a lot of Apache stuff in order to get the most mileage out of it. This won't happen overnight. :)
Sep
2
comment How can you install puppet on CentOS 7
Go poke around in /etc/yum.repos.d and see if you can find the stray configuration.
Sep
2
answered nginx Subdirectory Rewrites for MVC
Sep
2
comment How can you install puppet on CentOS 7
You appear to have mixed in something from EL6 on this system, perhaps the puppetlabs release RPM?
Sep
2
answered MySQL installation with Ansible on Debian Wheezy
Sep
2
comment Puppet master receiving a YAML error after upgrade to 2.7.25-2
Good luck. RHEL 4 is on extended life support and it's past time for migration plans for such boxes. I think Puppet Enterprise has a puppet agent build for EL4, though, if you want to go down that road.
Sep
2
comment Puppet master receiving a YAML error after upgrade to 2.7.25-2
That looks like the puppet from EPEL (which is ancient) rather than the one from puppetlabs (which is current). Do you specifically need to be this far out of date? Puppet Labs doesn't support 2.7 anymore.
Sep
2
comment has no MX record
What are these files supposed to be? I have none of them on my FreeIPA DNS server.
Sep
2
comment `rake db:migrate RAILS_ENV=production` gives error
Two things now: First, don't use other people's public IP addresses in your posts. Second, look at your logs and find out what's going on with postgresql.
Sep
2
comment Samba server on CentOS sees shared directories, but no files visible
Check your samba log and audit logs.
Sep
2
comment `rake db:migrate RAILS_ENV=production` gives error
The obvious solution is to start postgresql.