219 reputation
315
bio website
location Australia
age
visits member for 5 years, 8 months
seen yesterday

Hello, hows it going? I'm just stumbling my way through the code.


Mar
26
comment SASL PLAIN authenticating with primary domain, but not with virtual domain
Actually, I first did a symlink, reloaded and nothing was different. I then removed that, and moved sasldb2 instead. Reloaded, and still didn't work. So I changed master.cf to not allow chroot for submission. It still didn't work! I then rebooted the whole server and it worked. So I'm not sure exactly which one solved it. :) But I'm happy it worked
Mar
26
comment SASL PLAIN authenticating with primary domain, but not with virtual domain
Really appreciate the help! I think it is working now
Mar
26
comment SASL PLAIN authenticating with primary domain, but not with virtual domain
I did add verbose mode, it really outputs a lot of new information - I will update the post above. Otherwise, when I send an email here is what maillog outputs Mar 26 06:11:36 srv postfix/smtpd[29466]: connect from unknown[xx.xx.xx.xx] Mar 26 06:11:37 srv postfix/smtpd[29466]: warning: SASL authentication problem: unable to open Berkeley db /etc/sasldb2: Not a directory Mar 26 06:11:37 warning: SASL authentication failure: no secret in database Mar 26 06:11:37 srv postfix/smtpd[29466]: warning: unknown[xx.xx.xx.xx]: SASL LOGIN authentication failed: authentication failure
Mar
25
comment SASL PLAIN authenticating with primary domain, but not with virtual domain
I made it default now, but still when I authenticate it gives the same error. I looked at maillog when I send an email using the sasl credentials and I get the error: warning: SASL authentication problem: unable to open Berkeley db /etc/sasldb2: Not a directory. If I do sasldblistusers2 it appears to be working correctly. It looks normal to me: [root@srv etc]# ls -l /etc/sasldb2 -rw-r----- 1 root postfix 12288 Mar 24 03:48 /etc/sasldb2 Why does it expect sasldb2 to be a directory?
Mar
24
comment SASL PLAIN authenticating with primary domain, but not with virtual domain
Thanks a lot for that extensive instructions! I think I followed your instructions exactly. When you generate Base64 credentials, do you leave in the three 0's? e.g. \000myemail@domain.com\000mypassword? I've tried a couple ways but still get authentication failed, but now it does appear to at least try the sasldb you helped me create. I've updated the post with the saslfinger -s output - is there anything you can see there that is a problem?
Feb
25
comment SASL PLAIN authenticating with primary domain, but not with virtual domain
@masegaloeh that is what I am trying to also work out. currently the username I'm using is just a system user. I'm using the credentials of the user account. As though it isn't even using sasl, but when I send a mail the maillog shows that there is a sasl login with just a username - but not logging in with an email address! 0.o
Feb
25
comment SASL PLAIN authenticating with primary domain, but not with virtual domain
sasldblistusers2 only outputs the email address I just added after your comment, not the username I use to currently access my primary account.
Feb
25
comment SASL PLAIN authenticating with primary domain, but not with virtual domain
That's a good question. I don't yet, but don't understand why I'm telling it to use sasldb but it is letting me log in with a regular username. i.e. I hadn't previously added a password to sasldb to my knowledge and I've been using email like this for a while.
Feb
25
comment SASL PLAIN authenticating with primary domain, but not with virtual domain
I created a password ok, but trying to verify with testsaslauthd throws an error: connect() : No such file or directory. What I also don't understand is why with sasldb it says then to login with whole email address, not username, but my primary domain logs in with just the system username, not an email.
Feb
23
comment postfix specify limited relay domain while allowing sasl-auth relay
Yep. Great documentation and super useful errors in the logs make working with Postfix uber fun.
Nov
12
comment I added some options to stop spam with Postfix, but now won't send email to remote domains
Actually, I'm not sure this was the issue, but perhaps a network issue. I removed "reject_unknown_recipient_domain" which then revealed the following in my logs when sending to my test gmail account " connect to gmail-smtp-in.l.google.com[2a00:1450:400c:c05::1b]:25: Network is unreachable" - it then appears to keep trying, and then relays a few seconds later. That looks like an ipv6 there, but then the relay that works appears to be via regular old ip. To be honest, I have no idea what is going on.
Nov
12
comment I added some options to stop spam with Postfix, but now won't send email to remote domains
@zhenech thanks for the tip though. Makes sense what you said. I'm going to try running with just spamhaus for a while because I am a super newb, configuring more difficult things is harder, and i'm getting rained on with spam.
Nov
12
comment I added some options to stop spam with Postfix, but now won't send email to remote domains
Thanks for that tip Nick. I've changed the order of the rules now.
Nov
12
comment I added some options to stop spam with Postfix, but now won't send email to remote domains
@zhenech Thanks for explaining all that. But this wouldn't be the reason why I can't send an outgoing mail would it?
Nov
12
comment I added some options to stop spam with Postfix, but now won't send email to remote domains
@michaelhampton It just has my nameserver Ip's 'nameserver 77.235.33.38 nameserver 77.235.33.116'
Nov
12
comment I added some options to stop spam with Postfix, but now won't send email to remote domains
@zhenech ok - I thought these would just block spam emails that have been added to these spam databases - are you saying good domains get added to these lists?
Nov
12
comment I added some options to stop spam with Postfix, but now won't send email to remote domains
@MadHatter I added the dig mx of gmail.com into the question. It seems like it is ok, isn't it?
Sep
23
comment Nginx with www and without www
thanks again - seemed I could only find rewrite examples everywhere.
Sep
22
comment Nginx with www and without www
unbelievably simple.
Sep
22
comment I have setup mail.mydomain.org, but now for another virtual domain, i'd like mail.thatdomain.org as well - how?
I see. That has helped a bit. I've added my 2 domains to this directive. But when I use the alias domain as a mail server, what comes up in the output returned from postfix is that it using whatever I list under the directive for myhostname. e.g. bounces are not returned by the alias domain, but by the myhostname. So if you send with mail.thisdomain.org (the virtual alias) it bounces with mail.myhostname.org - which isn't great. Any ideas?