123 reputation
6
bio website
location
age
visits member for 1 year, 10 months
seen Jun 26 at 12:36

Aug
8
awarded  Popular Question
Jun
5
comment Xubuntu Desktop 14.04 - service mysql start unknown job
Exussum gave good solution. I'm not great at linux yet so I assumed if I added myself to the sudo group and edited sudoers file I should have done that without typing sudo. It seems I have to do that anyway.
May
30
asked Xubuntu Desktop 14.04 - service mysql start unknown job
Sep
6
accepted Ubuntu server 12.04, apache2 - very slow response to first request
Sep
5
answered Ubuntu server 12.04, apache2 - very slow response to first request
Sep
5
comment Ubuntu server 12.04, apache2 - very slow response to first request
I have found a problem. I had to turn off the KeepAlive. There were to many new connections and acutally most of them wasn't long enough to keep the KeepAlive on. I trurned it off so now the connections are not blocked.
Sep
5
comment Ubuntu server 12.04, apache2 - very slow response to first request
It seems it is not related to HTTPS. I switched traffic to pure HTTP and initial slow still exists. This problem really is killing me.
Sep
4
comment Ubuntu server 12.04, apache2 - very slow response to first request
It may be it, but why CPU usage is so low(150-200% / 1600%)?
Sep
4
awarded  Commentator
Sep
4
comment Ubuntu server 12.04, apache2 - very slow response to first request
I'll try to check your suggestion altough I'm not sure whether it is SSL handshake problem. As I wrote in question when all traffic was without SSL - https was fast and http was slow.
Sep
4
comment Ubuntu server 12.04, apache2 - very slow response to first request
@pehrs - cpu load is low its 150% on 1600% available.
Sep
4
comment Ubuntu server 12.04, apache2 - very slow response to first request
This is 4096 SSL. HostnameLookups is set to off. This is default LAMP installation during ubuntu installation so I guess localhost is set fine. I changed only MaxRequestsPerClient to 20000 in mpm sections.
Sep
4
asked Ubuntu server 12.04, apache2 - very slow response to first request
Sep
2
comment Should CPU usage be so low while memory usage is high on heavy mysql server?
I think I've found the cause. It was about Apache mpm prefork and worker config. The param MaxRequestsPerClient was set to 0 (by default!) while I've read it should never be set to 0. I changed to 10000 and puf! loadtime dropped to 20-40 ms. Weird default value.
Aug
28
comment Should CPU usage be so low while memory usage is high on heavy mysql server?
I carefully looked through munin stats and I guess I've found where the slow comes from. HTTP LoadTime of a page hits even 8s sometimes !
Aug
28
awarded  Scholar
Aug
28
comment Should CPU usage be so low while memory usage is high on heavy mysql server?
Thank you for such a good explanation. I'm more a programmer than server administrator so I wasn't sure whether I missed sth in the server configuration or did some mistakes but it seems it's ok. Thanks again.
Aug
28
accepted Should CPU usage be so low while memory usage is high on heavy mysql server?
Aug
28
comment Should CPU usage be so low while memory usage is high on heavy mysql server?
Database is InnoDB type. No MyISAM tables.
Aug
28
comment Should CPU usage be so low while memory usage is high on heavy mysql server?
I added my.cnf.