196 reputation
5
bio website
location Naarden, Netherlands
age 28
visits member for 1 year, 8 months
seen Mar 4 at 13:19

Jan
21
comment Coverting MySQL SQL statements to SQL Server
Ah, sorry, sysadmin is the server-wide administrator role. My mistake. I meant db_owner. See msdn.microsoft.com/en-us/library/ms189121.aspx That implies all the other roles, so simply checking db_owner should be enough.
Jan
21
awarded  Commentator
Jan
21
comment Coverting MySQL SQL statements to SQL Server
For the GRANT ALL PRIVILEGES ON *.*, you can better add this user (so the user on database-level, not the login) to the role sysadmin. This is a predefined role where you can do everything you'll need, so just adding this user to this role will give you the necessary permissions. See msdn.microsoft.com/en-us/library/ms189775.aspx (for SQL 2012; older versions use msdn.microsoft.com/en-us/library/ms187750(v=sql.105).aspx. Or just the right-click menu on the database user in SQL Server Management Studio.
Jan
21
comment Coverting MySQL SQL statements to SQL Server
The "for" and "from" are the same, just different syntax to comply to different (legacy) SQL languages. As I said, the @'%' or @'localhost' don't exist in SQL server; if you have a valid login and you can make a network connection to the server, you can login.
Jan
21
answered Coverting MySQL SQL statements to SQL Server
Jan
21
awarded  Tumbleweed
Jan
14
asked Logwatch configured for nginx with custom log format gives empty output
Jan
1
comment CNAME redirects behaving differently for two domains
The headers I'm getting at www.oliverhaslam.com include X-Powered-By: PHP/5.3.10-1ubuntu3.4 and X-Pingback: http://oliverhaslam.com/wordpress/xmlrpc.php. That tells me that the www.oliverhaslam.com is not redirected by apache itself, but by PHP and specifically Wordpress..
Dec
31
comment Virtualhost priority
@Dylan It seems then like Apache can't match the hostname. Or like NameVirtualHost * is not included in the configuration. Apache takes the first VirtualHost that matches. If you put the wildcard one first in the file, it's expected behavior that then also phpmyadmin.domain.tld is handled by the wildcard. So the wildcard should go last. If Apache can't find the requested hostname at all, it is again taking the first VirtualHost it can find. Are there no other VirtualHosts defined? Does this maybe help in debugging yourself?
Dec
31
comment Apache 2.4 - Have I been hacked?
And you're the only one using it? And there's also no .htaccess file anywhere with any authorization configured?
Dec
31
answered Apache 2.4 - Have I been hacked?
Dec
30
answered certificate working on IP but not on URL
Dec
30
awarded  Supporter
Dec
30
comment Virtualhost priority
@Dylan Can you post your new VirtualHost configuration? To get a complete overview and check for the reason for that to happen?
Dec
30
comment Virtualhost priority
And now combine the reply of @ShaneMadden and mine and you'll get a working situation ;)
Dec
30
awarded  Teacher
Dec
30
answered Virtualhost priority
Dec
30
comment CNAME redirects behaving differently for two domains
Well, if I visit www.oliverhaslam.com, I see in my browser log that I'm getting redirected to oliverhaslam.com by Wordpress. This is not something that has anything to do with Apache or the DNS; this is probably Wordpress behavior. As that completely depends on your settings in Wordpress, and I don't know anything about those, I can't explain this exactly. But the forwarding seems to be done by Wordpress, so look there instead of in Apache configs..
Dec
30
comment Remove cookies by cookie name in nginx reverse proxy
You're right about that. Edited my response.
Dec
30
revised Remove cookies by cookie name in nginx reverse proxy
proxy_set_header works to the backend, not the frontend