Student of Hogwarts

less info
106 reputation
5
bio website
location
age
visits member for 1 year, 6 months
seen Feb 19 '13 at 12:01

Nov
30
awarded  Popular Question
Feb
19
comment Why does ProFTPd stop at Entering Passive Mode on Debian on a Windows Virtualbox?
@MDMarra Can I ask why this was closed as off topic?
Feb
12
awarded  Scholar
Feb
12
awarded  Supporter
Feb
12
accepted Why does ProFTPd stop at Entering Passive Mode on Debian on a Windows Virtualbox?
Feb
12
comment Why does ProFTPd stop at Entering Passive Mode on Debian on a Windows Virtualbox?
It turned out what you wrote is everything that should be needed. The problem was that the ports I forwarded and used (49152-49155) didn't work for some strange reason. I tried 5000 to 5003 instead, and it just magically worked. Maybe those ports were already in use, or else there has got to be something wrong with Oracle Virtualbox on these ports. Anyway, thanks for you time! I do really appreciate people like you trying to help, spending their time for others who have struggled without getting this to work!
Feb
12
comment Why does ProFTPd stop at Entering Passive Mode on Debian on a Windows Virtualbox?
Okay, so I'm using Debian as the production server, and so I'm using Debian as the testing server. So on my WINDOWS computer, I have installed Debian on Virtualbox. I set the network adapter to NAT, and have port forwarded 80, 22, 21, 49152-49155. This way I can develop on my Windows computer and SSH into the Debian and upload the files via FTP just like it was an external server residing on it's own IP address. So when I connect to localhost:80, it will actually be redirected into the VM to Debian, same with 21 for FTP.
Feb
12
comment Why does ProFTPd stop at Entering Passive Mode on Debian on a Windows Virtualbox?
Thank you very much for the reply! But it didn't work, unfortunately. Same output as always..
Feb
12
awarded  Editor
Feb
12
revised Why does ProFTPd stop at Entering Passive Mode on Debian on a Windows Virtualbox?
added 162 characters in body
Feb
12
comment Why does ProFTPd stop at Entering Passive Mode on Debian on a Windows Virtualbox?
@Sacx I have already tried this, tried with MasqueradeAddress as well. I opened the defined ports in PassivePorts on the NAT adapter in the Virtualbox settings.
Feb
12
awarded  Student
Feb
12
asked Why does ProFTPd stop at Entering Passive Mode on Debian on a Windows Virtualbox?