Reputation
1,108
Top tag
Next privilege 2,000 Rep.
Edit questions and answers
Badges
3 12 29
Impact
~90k people reached

  • 0 posts edited
  • 5 helpful flags
  • 14 votes cast
Feb
20
comment Bug setting up stunnel server: `SSL3_GET_CLIENT_HELLO:wrong version number`
Do you still want me to run Process Monitor?
Feb
20
comment Bug setting up stunnel server: `SSL3_GET_CLIENT_HELLO:wrong version number`
Here's the capture from Wireshark with SSL3 enabled: db.tt/qojUw4DR
Feb
20
comment Bug setting up stunnel server: `SSL3_GET_CLIENT_HELLO:wrong version number`
Trying to add sslVersion = all results in this error: Service [https]: 'sslVersion = TLSv1' is required in FIPS mode.
Feb
20
comment Bug setting up stunnel server: `SSL3_GET_CLIENT_HELLO:wrong version number`
I added the log output in the preceding comment, with SSL3 enabled as you requested. Any insights?
Feb
19
comment Bug setting up stunnel server: `SSL3_GET_CLIENT_HELLO:wrong version number`
It didn't work even when I removed the NO_SSLv3. This is the log output from that session: gist.github.com/cool-RR/4981928
Feb
18
comment Bug setting up stunnel server: `SSL3_GET_CLIENT_HELLO:wrong version number`
Included it now
Feb
18
revised Bug setting up stunnel server: `SSL3_GET_CLIENT_HELLO:wrong version number`
added 112 characters in body
Feb
18
comment Bug setting up stunnel server: `SSL3_GET_CLIENT_HELLO:wrong version number`
I increased the bounty on the question to 100 points.
Feb
17
comment Bug setting up stunnel server: `SSL3_GET_CLIENT_HELLO:wrong version number`
I added the log output to the question.
Feb
17
revised Bug setting up stunnel server: `SSL3_GET_CLIENT_HELLO:wrong version number`
added 2804 characters in body
Feb
16
comment Bug setting up stunnel server: `SSL3_GET_CLIENT_HELLO:wrong version number`
(Fixed bad link.)
Feb
16
comment Bug setting up stunnel server: `SSL3_GET_CLIENT_HELLO:wrong version number`
(Fixed bad link.)
Feb
16
comment Bug setting up stunnel server: `SSL3_GET_CLIENT_HELLO:wrong version number`
@MirceaVutcovici Sorry, fixed now.
Feb
16
revised Bug setting up stunnel server: `SSL3_GET_CLIENT_HELLO:wrong version number`
added 58 characters in body
Feb
16
comment Bug setting up stunnel server: `SSL3_GET_CLIENT_HELLO:wrong version number`
Binary file added to question.
Feb
16
awarded  Popular Question
Feb
15
comment Bug setting up stunnel server: `SSL3_GET_CLIENT_HELLO:wrong version number`
I've done a Wireshark capture and linked to it in the question.
Feb
15
comment Bug setting up stunnel server: `SSL3_GET_CLIENT_HELLO:wrong version number`
I've done a Wireshark capture and linked to it in the question.
Feb
15
revised Bug setting up stunnel server: `SSL3_GET_CLIENT_HELLO:wrong version number`
added 149 characters in body
Feb
13
comment Bug setting up stunnel server: `SSL3_GET_CLIENT_HELLO:wrong version number`
I've updated the question with more details. Do you still need me to do a network capture?