Reputation
Top tag
Next privilege 200 Rep.
See reduced ads
Badges
2 12
Impact
~15k people reached

  • 0 posts edited
  • 0 helpful flags
  • 5 votes cast
Jun
16
comment Blank page when using IIS custom error pages
Thanks, unfortunately that's just taken me further into the rabbit hole. I can't enable failed request tracing as it looks like I don't have that installed (!!?). I can't afford to mess things up while the server's in heavy use and installing extra software seems a bit risky - can't afford for windows to want to restart after the install. Have to do this late at night or something.
Jun
16
comment Blank page when using IIS custom error pages
Me neither - thanks anyway. Just wish I could get some kind of clue or error report, but IIS likes keeping secrets
Jun
16
comment Blank page when using IIS custom error pages
Thanks - that makes sense. Unfortunately I tried that and now it's just serving the default 401 page again. Also tried enabling Anonymous authentication on the errors folder, but that just gives the empty page again. Any more ideas?
Jun
15
asked Blank page when using IIS custom error pages
Mar
12
awarded  Notable Question
Feb
2
awarded  Popular Question
Dec
10
awarded  Popular Question
Nov
11
awarded  Popular Question
Oct
13
awarded  Notable Question
Oct
11
comment How to use gitlab without hostname
Thanks, unfortunately I don't manage all of the (potential) client machines as we're also using external developers. At the moment they're not using git but the plan is to move our existing svn repos to git so I need a simple way to allow them to connect. Changing config only on the single machine that is causing this seemed the obvious answer, rather than making network wide changes or forcing external developers to change their setup.
Oct
11
asked How to use gitlab without hostname
Sep
24
awarded  Autobiographer
Aug
19
comment Using gitlab behind Apache proxy all generated urls are wrong
Agreed - it wants to sit on its own server. In the end my answer wasn't quite as simple. Editing the config file directly - despite dire warnings that the config ill be removed on updates - was the only solution. the install script couldn't cope with how I needed to set things up.
Aug
19
awarded  Scholar
Aug
19
comment Using gitlab behind Apache proxy all generated urls are wrong
Unfortunately as I installed the package from the URL in the question, I was discouraged from directly editing the config (and indeed at the next update I understand I'll need to tweak the settings again as they'll be overwritten by the ruby script that does the config) - but this answer sent me in the right direction so it gets +1.
Aug
19
accepted Using gitlab behind Apache proxy all generated urls are wrong
Aug
19
awarded  Commentator
Aug
19
comment Using gitlab behind Apache proxy all generated urls are wrong
thanks @gparent - making me look for gitlab.yml fixed the issue although at the top it tells me not to edit that file manually. making the changes directly in there did there trick though. Add an answer to that effect and I'll credit you for it.
Aug
19
revised Using gitlab behind Apache proxy all generated urls are wrong
added 16 characters in body
Aug
19
comment Using gitlab behind Apache proxy all generated urls are wrong
thanks all for comments so far - I've posted my apache config to make things a bit clearer about what's going on