Reputation
5,334
Top tag
Next privilege 10,000 Rep.
Access moderator tools
Badges
1 15 27
Newest
 nginx
Impact
~466k people reached

  • 0 posts edited
  • 1 helpful flag
  • 97 votes cast
11h
awarded  nginx
Jan
30
reviewed Approve ProFTPD/vsftpd readonly/readwrite access depending on connection source?
Jan
30
reviewed Approve Allow vsftpd user to upload only to a single directory
Jan
30
answered match special characters in url in nginx
Jan
21
comment NGINX wont start: localtion directive is not allowed
Can you update the question with your new config?
Jan
21
answered Nginx - Caching/processing of data when uploading a file over a reverse proxy
Jan
21
comment NGINX wont start: localtion directive is not allowed
No, that would just help you spot problems easier. The problem really is because there's a server block opening tag missing. Open your config in an editor that shows line numbers and look at line 100. You're closing your server block and then immediately opening a location block. If the file is auto generated it sounds like a bug in the control panel software.
Jan
21
answered NGINX wont start: localtion directive is not allowed
Jan
20
reviewed Approve sudo NFS SUID not working
Jan
20
reviewed Approve need the name of http_host for a htaccess rewrite condition
Jan
19
reviewed Approve Deploying R on Work Server
Jan
19
reviewed Approve drupal8 tag wiki
Jan
14
comment Disable nginx fastcgi_cache when disk is full
Nginx doesn't really allow you to reference available disk space anywhere, so I don't think it's possible to do via normal nginx. There might be a way to do it with the Lua module but then you're moving into a complex solution and may as well just set you proper server monitoring to warn you if the disk space is close to running out.
Jan
12
comment NGINX port proxy not working
It's difficult to debug based on just "it's not working", but it might be because I messed up the proxy pass line, it should include http://, please see my revised answer.
Jan
12
revised NGINX port proxy not working
Add http:// to the proxy_pass directive.
Jan
12
revised NGINX port proxy not working
added 404 characters in body
Jan
12
comment NGINX port proxy not working
@Frank If your backend application is listening on port 8080 now then you need to tell nginx to send requests to that port yes. I have modified my answer to show an example of doing that.
Jan
12
answered NGINX Reverse proxy not loading resources
Jan
12
reviewed Approve Error denying permissions on GPO with Powershell
Jan
12
answered NGINX port proxy not working