127 reputation
14
bio website
location
age
visits member for 4 years, 6 months
seen Dec 1 at 9:22

Jun
10
awarded  Notable Question
Mar
28
comment linux macvlan - stop from broadcasting hostname
Additionally, anybody playing around with macvlan stuff should be aware of the "arp flux" problem; if your ssh sessions are randomly dropping, then I suggest you look here: serverfault.com/questions/207480/… and then here: linux-ip.net/html/ether-arp.html
Mar
28
accepted linux macvlan - stop from broadcasting hostname
Mar
27
comment linux macvlan - stop from broadcasting hostname
Awesome. That's exactly what I meant. Avahi was indeed the culprit, and there is an /etc/avahi/avahi-daemon.conf with an "allow-interfaces" and "deny-interfaces" area.
Mar
27
asked linux macvlan - stop from broadcasting hostname
Oct
5
awarded  Supporter
Oct
5
accepted /etc/passwd continually accessed
Oct
5
comment /etc/passwd continually accessed
I'm marking this as the answer, as it helped me the most, but what ended up actually clinching this for me was enabling block dumping (echo 1 > /proc/sys/vm/block_dump) and take a look at it with dmesg to see which processes were accessing the disk. Much more reliable than iotop. Turns out, sar was running continually, writing out to /var/log/sa/saXX so I disabled that in cron.d, and all is well again.
Oct
4
comment /etc/passwd continually accessed
Sorry, by "nothing of interest", I meant it only contains commands that I would expect, nothing extremely out of the ordinary. Indeed, the most interesting thing was the bruteforce ssh logins coming in, which I believe may account for the /etc/passwd accesses
Oct
4
comment /etc/passwd continually accessed
I may be barking up the wrong tree here, as that log file doesn't contain anything of interest. I'm thinking it might just be random ssh login attempts, so the source of all the I/Os, (much greater than the ssh login attempts would account for) might instead be a result of a kernel bug. I'll attempt to update my kernel and see how that goes!
Oct
4
awarded  Student
Oct
4
asked /etc/passwd continually accessed
Sep
19
awarded  Popular Question
Jun
22
awarded  Scholar
Jun
22
accepted redirect outbound traffic to internal IP using iptables
Jun
22
comment redirect outbound traffic to internal IP using iptables
Hmmm, that doesn't seem to work, unfortunately. I see now, by further inspecting the current iptables config that you are absolutely correct, the webgui port forwarding rules are just iptables rules. :) I will just manually shadow the inbound rules. Thank you for your help!
Jun
22
comment redirect outbound traffic to internal IP using iptables
That is very close to what I want, however, I want the packets to be processed by the port forwarding rules I have setup already for incoming traffic. I realize that I can mirror the port forwarding rules in the iptables ruleset, however it seems to me it would be better to have it all in one place. Is there a way to forward the traffic, instead of to "server.net.a.address", to "dd-wrt.net.b.address" so that the packets are processed properly? Thank you for your response!
Jun
22
asked redirect outbound traffic to internal IP using iptables