143 reputation
15
bio website
location Brisbane, Australia
age 31
visits member for 4 years, 4 months
seen Jan 21 at 7:34

Dec
24
comment Changing an `A` record to a `CNAME` without downtime
You just saved my bacon. Thank you. !
Dec
24
accepted Changing an `A` record to a `CNAME` without downtime
Dec
23
comment Changing an `A` record to a `CNAME` without downtime
Bitter and jaded is good. Better to learn from a battle scarred veteran than naively screw up like I have today ;p. The API looks quite promising - I'll give that a whirl, and then migrate to a better host once the shit has stopped hitting the fan. Thanks.
Dec
23
comment Changing an `A` record to a `CNAME` without downtime
No because you're not removing, you're changing, and any reasonable DNS host would commit the removal of the A record and addition of the CNAME all in one fell swoop And therein lies my problem - Dyn.com won't let me do it atomically. Which backs up your next point quite succinctly. I'll take your opinion and run with it - Is there a particular host you recommend as an alternative?
Dec
23
comment Changing an `A` record to a `CNAME` without downtime
I might be misunderstanding the process, but deleting the existing A record would potentially result in cached NXDOMAIN responses? Our SOA NXDOMAIN TTL is 30 minutes, which I don't appear to be able to change in dyn.com
Dec
23
comment Changing an `A` record to a `CNAME` without downtime
Amazon explicitly states that the ELB IP address may change without warning, and that we must use a CNAME. The TTL is already 60 seconds, however the SOA NXDOMAIN TTL is 1800 seconds, which I don't appear to be able to change with dyn.com - so removing the existing A record will potentially result in up to 30 minutes down (so far as I can tell).
Dec
23
asked Changing an `A` record to a `CNAME` without downtime
Dec
4
awarded  Notable Question
Feb
25
awarded  Popular Question
Sep
27
awarded  Scholar
Sep
27
awarded  Critic
Sep
27
accepted Why is my SPF Record not working?
Sep
24
awarded  Supporter
Sep
24
comment Why is my SPF Record not working?
I originally had ~all, and changed it to -all a few days ago, which didn't seem to make much difference.
Sep
24
awarded  Student
Sep
24
asked Why is my SPF Record not working?