Reputation
3,043
Top tag
Next privilege 5,000 Rep.
Approve tag wiki edits
Badges
9 10
Newest
 Nice Answer
Impact
~216k people reached

  • 0 posts edited
  • 0 helpful flags
  • 35 votes cast
Jun
10
awarded  Nice Answer
Apr
23
answered HAProxy 1.5 Serving Static Assets Very Slowly
Dec
19
awarded  Yearling
Jul
28
comment HAProxy is swapping (Major Faults) when Serving Web Sockets
OK so this instance is taking 15GB of RAM currently and its configuration allows it to grow up to 40G. Thus there's nothing alarming since there are 34G available as cache. It's just that the system has decided that part of the memory was better used for the cache than for haproxy. Actually it could make sense to disable swapping on this machine, or you risk getting into hard-to-debug issues (eg: slow connection times). BTW, you still need to ensure that the 34GB are really cache. For this you can echo 3 > /proc/sys/vm/drop_caches.
Jul
28
answered HAProxy is swapping (Major Faults) when Serving Web Sockets
Jul
20
awarded  Good Answer
Apr
13
awarded  Nice Answer
Dec
19
awarded  Yearling
Dec
16
answered HAproxy for postfix
Nov
19
answered HAproxy double memory usage after reload
Sep
2
answered How do you use ELB's support for PROXY protocol version 1 securely?
Jul
14
awarded  Necromancer
Apr
24
comment haproxy redirect keep querystring
no, look, the request is changed, not only the domain.
Apr
24
answered TCP connection stuck in SYN_RECV state despite ACK received, Linux 2.6.18, embedded, ARM
Apr
5
answered Using URL parameters for load balancing with HAProxy
Mar
2
awarded  haproxy
Jan
7
answered is this some sort of haproxy bug?
Dec
31
awarded  Nice Answer
Dec
27
revised HAProxy only working for localhost
added 254 characters in body
Dec
27
answered HAProxy only working for localhost