226 reputation
1210
bio website valentin.hilbig.de
location DE
age
visits member for 3 years, 8 months
seen Jun 22 at 0:06

Unix-Geek


Aug
9
comment nginx url rewriting: difference between break and last
pubbs.net link is broken as the domain was taken over. Sorry, was not able to find where it should point. ;(
Jul
4
awarded  Supporter
Jul
4
comment How to tell which local branch is tracking which remote branch in Git?
+1 Your answer gave me exactly what I needed: git rev-parse --symbolic-full-name HEAD vs. git rev-parse --symbolic-full-name HEAD@{u}, thanks!
Mar
13
awarded  Popular Question
Jan
6
answered How do I use git-push --mirror with git-shell in SSH?
Nov
1
comment Unix shell: easy way to get IP from hostname
Thanks. And updated for IPv6.
Nov
1
revised Unix shell: easy way to get IP from hostname
added link to tool written for IP resolving purpose
Oct
31
awarded  Teacher
Oct
31
answered Unix shell: easy way to get IP from hostname
Jul
21
awarded  Scholar
Jul
21
accepted Switch on PAM debugging to Syslog
Jul
21
comment Switch on PAM debugging to Syslog
OK, well, I think you answer accutally is correct! It's not the answer's fault that PAM is mute. So for the time being I accept it as "solution" until PAM capitulates. Thanks.
Jul
21
comment Switch on PAM debugging to Syslog
Thanks for the hint, but unfortunately this does not help: pam_unix(sshd:auth): unrecognized option [verbose=1]
Jul
21
comment Switch on PAM debugging to Syslog
I forgot to mention that you must set PermitEmptyPasswords yes in /etc/ssh/sshd_config of course, then PAM outputs something like pam_unix(sshd:auth): authentication failure, but still nothing to the debug channel nor any hint which PAM module caused the failure.
Jul
21
comment Switch on PAM debugging to Syslog
Here is how to create this trouble yourself on Debian: passwd -d user and then try to ssh into the box as this user. The output "failed password" in syslog has nothing to do with PAM debugging at all, so PAM stays silent.
Jul
21
comment Switch on PAM debugging to Syslog
I checked it, sorry, your answer is not the solution. PAM still stays silent. Perhaps this is a nullok special that just this module is lacking debugging. Let me say it with this words: Lacking debugging on such a crucial central piece of code is a worse nightmare than just being haunted by Freddy Kruger.
Jul
21
comment Switch on PAM debugging to Syslog
Good answer but I think I had syslog debugging on. I will check it out.
May
12
awarded  Student
Mar
28
awarded  Tumbleweed
Mar
21
awarded  Editor