270 reputation
212
bio website
location London, United Kingdom
age
visits member for 3 years, 7 months
seen Sep 2 at 11:06

Sep
2
awarded  Popular Question
Aug
24
comment Poor network performance with KVM (virtio drivers) - Update: with vhost_net
As another test, I tried changing the compression type of the ssh connection (arcfour) and the speed increased (up to about 65MB/s). In this case it's sounding a lot like CPU throttling, as you said, or at least that it's CPU bound. Weird that the older Dell Servers don't seem to have the same issue, yet run the same software/kernel versions. Thanks again, will try your other suggestions now.
Aug
24
comment Poor network performance with KVM (virtio drivers) - Update: with vhost_net
Thanks devicenull, very helpful! Testing with iperf does seem to immediately yield gigabit speeds, so it may have been a bit stupid of me to think I'd get the same performance out of rsync/scp.
Aug
17
comment Poor network performance with KVM (virtio drivers) - Update: with vhost_net
Usually, I'd write it up, but I'm still trying to find the issue, all well and good I've got some improvement, but it's still under performing by almost 50% of what I'd expect it to.
Aug
16
awarded  Notable Question
Aug
15
comment Poor network performance with KVM (virtio drivers) - Update: with vhost_net
Thanks again dyasny, I'll see if there's any updates to those cards
Aug
15
comment Poor network performance with KVM (virtio drivers) - Update: with vhost_net
That's what I'd have expected too. hmm :(
Aug
14
comment Poor network performance with KVM (virtio drivers) - Update: with vhost_net
Yes, definitely tried that. Just out of interest, what kind of network performance have you seen between host and guest?
Aug
14
revised Poor network performance with KVM (virtio drivers) - Update: with vhost_net
Added further testing notes, slight improvements, but still not the raw performance I was looking for
Aug
13
comment Poor network performance with KVM (virtio drivers) - Update: with vhost_net
I've set these to off in a test just now, but hasn't helped as yet. Any further information on 'playing' with them? Do I alter the bridged ethernet port on the host? The ethernet port? Or just the eth0 adapater inside each guest?
Aug
13
comment Poor network performance with KVM (virtio drivers) - Update: with vhost_net
I specifically haven't enabled them at all as yet, not on the switch or any of the machines
Aug
13
asked Poor network performance with KVM (virtio drivers) - Update: with vhost_net
Aug
1
accepted KVM 802.1q (tagged VLAN setup)
Jul
2
awarded  Curious
Mar
12
awarded  Teacher
Mar
12
answered Puppet: include other files depending on hostname
Mar
12
answered nginx and apache2 conflict - 403 Forbidden
Oct
21
awarded  Popular Question
Sep
10
answered RAID Recovery on a QNAP TS-869U-RP
Sep
9
asked RAID Recovery on a QNAP TS-869U-RP