111 reputation
4
bio website misc.lv
location Latvia
age 29
visits member for 3 years, 9 months
seen May 23 at 10:36

Feb
5
comment Slow 802.11n on custom-built router
I tried to enable/disable wmm_enable and it did not give desired results (I believe it was even worse without WMM). As for speeds being just "faster than g" - local network was up to 20-21 MB/s which is MUCH faster than g. The problem was that accessing foreign resources was awfully bad. It had basically nothing to do with my ISP, tested that. Anyway, it doesn't matter anymore as I've moved since then, changed ISP from 100Mbps fiber optics (which is even faster now, ISP upgraded speeds to 250Mbps) to 10-12 Mbps 3G connection and replaced custom-built router with Mikrotik's router.
Mar
20
comment Slow 802.11n on custom-built router
Switching to 5GHz did not help - foreign internet is still slow.
Mar
19
awarded  Commentator
Mar
19
comment Slow 802.11n on custom-built router
As for 5GHz you mentioned in one of previous comments - I might try to switch to it, but I have to find out how to do it (google, google, google, ...). Currently hostapd just says that my hardware does not support it - might be because of country codes here and there. iw list lists 5GHz channels with "passive scanning, no IBSS", some with additional "radar detection" notes. But that's unrelated to the current problem.
Mar
19
comment Slow 802.11n on custom-built router
Now I'm confused. I thought that WMM is disabled by default, so I tried ommiting it, but not setting to 0. If I set it to 0, wmm_enabled=0, I get ~30 Mbps down and ~22 Mbps up for both local and foreign internet - much better for foreign internet, but ~3x worse for local. Also, WLAN (between laptop and router) is somewhere aroud 6-7 MB/s - 3x slower than with WMM enabled. Will take a closer look at those WMM settings.
Mar
19
comment Slow 802.11n on custom-built router
There's no such thing as "the old 11g AP" - both 802.11g and 802.11n are tested with the same machine. Switching between g and n is performed by enabling/disabling ieee80211n and wmm_enabled configuration parameters in hostapd.conf file.
Mar
19
comment Slow 802.11n on custom-built router
If it's not wireless, then why does 802.11g give much better speeds?
Mar
19
comment Slow 802.11n on custom-built router
I'm slightly tired now, at 5am, but while giving a quick look to that article, I noticed that it suggests to enable TCP window scaling to solve that issue. Another article states that on Linux it's enabled by default since 2.6.8. Neither disabling it, nor re-enabling did not change anything.
Mar
19
comment Slow 802.11n on custom-built router
I doubt so, I don't think my phone supports 5GHz. Also, if it was the RF part, wouldn't local network be affected as well? I'm easily getting >160Mbps speeds (real throughput) between client and router.
Mar
19
awarded  Editor
Mar
19
revised Slow 802.11n on custom-built router
added 26 characters in body
Mar
19
comment Slow 802.11n on custom-built router
I somehow missed that I can use channels below 3. Switching to ch1 made the network unusable. Switching to ch2 gives same slow speeds. Though, I just noticed that speedtest.net shows 8Mbps upload, when download is just 3Mbps.
Mar
19
comment Slow 802.11n on custom-built router
scottm32768, no, it didn't seem so. To be honest, I even thought that switching to 20MHz (automatic disabling 40MHz) might cause the problems, therefore I disabled the check that switches to 20MHz.
Mar
19
comment Slow 802.11n on custom-built router
As for the neighbors, there's one on ch11 (802.11g), I'm on ch3 and ch7 - no overlapping here. Other networks are so weak that I rarely see them (signal strength is around -90, -100 dBm for those).
Mar
19
comment Slow 802.11n on custom-built router
Well, if it was ISP, then both 802.11n and 802.11g would be slow. The funny thing is that while 802.11n works with 300-400 KB/s, 802.11g - with 2.7 MB/s (probably about the maximum what can be achieved in 802.11g). It shouldn't matter for ISP what type of network I use locally.
Mar
19
awarded  Student
Mar
19
asked Slow 802.11n on custom-built router
Apr
20
awarded  Supporter