10 reputation
5
bio website
location
age
visits member for 3 years, 4 months
seen Jan 19 '12 at 23:23

Aug
29
awarded  Popular Question
Apr
19
revised Sed regexp /d deleting whole file
added 33 characters in body
Apr
19
comment Sed regexp /d deleting whole file
First by seconds. Thank you...
Apr
19
revised Sed regexp /d deleting whole file
added 141 characters in body; added 6 characters in body
Apr
19
accepted Sed regexp /d deleting whole file
Apr
19
awarded  Scholar
Apr
19
accepted Setting up simple sandboxed sftp for one user
Apr
19
asked Sed regexp /d deleting whole file
Apr
14
comment Setting up simple sandboxed sftp for one user
Ah interesting will investigate this more.
Apr
13
comment Setting up simple sandboxed sftp for one user
Missed edit window: PAM disabled on next try, no joy. Should be PAM disabled on next try, it works.
Apr
13
comment Setting up simple sandboxed sftp for one user
Just a followup to this. I rebuilt the uvps (twice to confirm-confirm) incorporating the change (internal-sftp), ~sftpuser owned by root, and even properly set the locale [facepalm]... with PAM enabled on first try, no joy. with PAM disabled on next try, no joy. with PAM re-enabled, it works. I haven't found any references to this, and really don't know what to make of it - but hey, I have chrooted sftp working consistently - and I suppose this will probably help someone someday.
Apr
11
revised Setting up simple sandboxed sftp for one user
added 253 characters in body
Apr
11
awarded  Commentator
Apr
11
comment Setting up simple sandboxed sftp for one user
Okay just to be difficult, the server decided that PAM was now okay to use. Very bizarre. I re-enabled it in the sshd_config file (along with LogLevel DEBUG3), reloaded ssh Cyberduck and Netbeans can negotiate it. So essentially, WTF?!?! Looking through the DEBUG log, lots of info makes sense... very useful. Does PAM have a "reload" like feature that Disabling/Enabling it in sshd_config could trigger?
Apr
11
comment Setting up simple sandboxed sftp for one user
It seems (from skimming the docs for PAM) that it adds all kinds of features securely, not really adds security to normal authentication - and my impression on running a server is that you only add what you must. Please do correct me if I'm wrong on either count. I have to relocate from work to home in a second, when I get home i will sftp from cli w/ -v flag and we'll take a look at PAM if your still up for that... Again I really do appreciate you taking the time.
Apr
11
revised Setting up simple sandboxed sftp for one user
added 839 characters in body
Apr
11
comment Setting up simple sandboxed sftp for one user
That's quite kind rfelsburg. Will simply setting loglevel in the sshd_config do it, or is there another loglevel you are referring to? Also I guess after reading up on PAM for a half hour, I'm wondering if I'll be using it in any worthwhile way for this endeavor. Any thoughts on that for a one person LAPPP stack (Lin/Apache/Postgres/Php/Python) playground?
Apr
11
comment Setting up simple sandboxed sftp for one user
Just tried disabling PAM in the sshd_config and was able to gain access. So it looks like a misconfigured PAM is the culprit (or the bug I noted above). Don't know that I actually need PAM... but at least there's some clear and apparent cause here. Thanks again for responding. Off to update the main question.
Apr
11
comment Setting up simple sandboxed sftp for one user
Yes... and I even meant to mention that - long day. /etc/init.d/ssh reload
Apr
11
comment Setting up simple sandboxed sftp for one user
Thanks. Just tried... exact same result as the latest logs (EDIT03 above). Definitely worth a try.