547 reputation
627
bio website
location
age
visits member for 3 years, 2 months
seen 2 days ago

Aug
5
awarded  Popular Question
Jul
28
awarded  Notable Question
Jul
2
awarded  Curious
Jun
27
awarded  Notable Question
Jun
5
awarded  Notable Question
May
21
awarded  Popular Question
May
17
awarded  Notable Question
Apr
2
awarded  Popular Question
Jan
29
awarded  Popular Question
Jan
8
awarded  Popular Question
Dec
27
awarded  Popular Question
Dec
21
awarded  Popular Question
Dec
20
awarded  Popular Question
Dec
12
awarded  Popular Question
Nov
25
comment Puppet agent runs as a daemon but manifests are only applied when puppet agent is run manually?
@ShaneMadden @nandoP The issue was solved by by removing the puppetmaster cert on the puppet master puppetca clean puppetmaster.website.com which removed the puppetmaster ssl .pem key. After that I regenerated the puppet master cert sudo puppet master --no-daemonize --verbose, cleared/regenerated the client cert and everything worked out =).
Nov
24
comment Puppet agent runs as a daemon but manifests are only applied when puppet agent is run manually?
@ShaneMadden The daemon is running as root as ps auxf | grep puppet shows root 27284 0.1 11.4 151576 57448 ? Ss Nov22 2:58 /usr/bin/ruby1.8 /usr/bin/puppet agent I always run puppet agent --test as root
Nov
24
comment Puppet agent runs as a daemon but manifests are only applied when puppet agent is run manually?
@ShaneMadden This is from /var/log/syslog whenever the daemon runs... (/File[/var/lib/puppet/lib]) Failed to generate additional resources using 'eval_generate: SSL_CTX_use_PrivateKey:: key values mismatch however it runs perfectly when I do it manually with $ puppet agent --test. Any ideas what I am doing wrong?
Nov
24
comment Puppet agent runs as a daemon but manifests are only applied when puppet agent is run manually?
@nandoP @Iain running puppet agent -t --server=puppetmaster.website.com via cli casuses everything to work correctly. @Zoredache the [master] section was there by default when I installed puppet on the puppet clients. Would removing it fix this problem?
Nov
24
comment Puppet agent runs as a daemon but manifests are only applied when puppet agent is run manually?
I've pasted the contents of /etc/puppet/puppet.conf. The address of the server the agent is contacting is a FQDN which requires DNS to resolve.
Nov
24
revised Puppet agent runs as a daemon but manifests are only applied when puppet agent is run manually?
added 694 characters in body