23 reputation
15
bio website
location United States
age
visits member for 3 years, 7 months
seen Jan 18 at 18:05

Sep
15
awarded  Supporter
Nov
6
awarded  Notable Question
Jan
19
awarded  Popular Question
Mar
30
comment Postfix, saslauthd, mysql, smtp authentication problems
Thanks malloc, I guess I can only give a check to one solution, but did mention you for helping. It was Avery's suggestion to point me in the right direction about checking my DNS records. Thanks to both of you. I would give you some credit, but I can't do it cause I don't have 15 reputation yet ;)
Mar
30
awarded  Scholar
Mar
30
accepted Postfix, saslauthd, mysql, smtp authentication problems
Mar
30
revised Postfix, saslauthd, mysql, smtp authentication problems
Found a solution giving details
Mar
28
comment Postfix, saslauthd, mysql, smtp authentication problems
GREAT TOOL @AveryPayne intodns.com is baller!
Mar
28
comment Postfix, saslauthd, mysql, smtp authentication problems
edited my original question, yes, i've tested with that. Put it back in. So its funny that when I try to connect to the SMTP server from thunderbird on any port any combination of authentication methods I should at least get a postfix/smtpd[18280]: connect from mycomputer.corp.company.com[] type entry in any of my logs (looking at mail.log, syslog, auth.log) but I don't. Ports show open ACCEPT tcp -- anywhere anywhere tcp dpt:smtp ACCEPT tcp -- anywhere anywhere tcp dpt:ssmtp
Mar
28
revised Postfix, saslauthd, mysql, smtp authentication problems
changed /etc/postfix/main.cf and reloaded
Mar
28
comment Postfix, saslauthd, mysql, smtp authentication problems
I have played with those settings, thanks for clarifying that they need to be set. I don't see any postfix/master logs in my /var/log/mail.log file when I try to connect, minus the initial log of postfix/master[17520]: reload -- version 2.7.0, configuration /etc/postfix when I reload postfix. No additional logs when testing with thunderbird. I only see imapd-ssl connections.
Mar
28
comment Postfix, saslauthd, mysql, smtp authentication problems
Actually might try this tutorial for a mail server in a few hours or so if I don't get anything working. Seems up to date.
Mar
28
revised Postfix, saslauthd, mysql, smtp authentication problems
looking at the config file
Mar
28
comment Postfix, saslauthd, mysql, smtp authentication problems
with remote telnet, no other computers on the LAN i own, so its totally remote (will be getting rid of it after these testing purposes) I get RCPT TO:another@address.com giving Relay access denied
Mar
28
comment Postfix, saslauthd, mysql, smtp authentication problems
yes, sending through telnet works, sending from the server itself of course. Also I have a self signed certificate, which thunderbird saw and complained about, but I accepted the self signed cert. And I also tried those suggestions about using different names.
Mar
27
suggested rejected edit on Postfix, saslauthd, mysql, smtp authentication problems
Mar
27
comment Postfix, saslauthd, mysql, smtp authentication problems
Ok I feel like I am close. From reading SASL_README I found that my /var/spool/postfix/var/run/saslauthd/ needed proper permissions for sasl to be able to read+write. That location also needed a symbolic link to /etc/default/saslauthd/ Now my testsaslauthd works, and gives OK "Success" Still having problems because thunderbird doesn't want to work.
Mar
26
awarded  Editor
Mar
26
revised Postfix, saslauthd, mysql, smtp authentication problems
more information about the problem
Mar
26
awarded  Student