394 reputation
717
bio website
location
age 41
visits member for 3 years, 2 months
seen Oct 29 at 6:44

Oct
6
accepted autossh does not kill ssh when link down
Oct
6
comment autossh does not kill ssh when link down
And after re-reading the autossh man page now I remember why I set -M 0: it is not easy to use a monitoring port, and it is indirectly discouraged: In many ways this may be a better solution than the monitoring port
Oct
6
comment autossh does not kill ssh when link down
Thanks, this makes sense. I indeed meant "client process", not server process.
Oct
3
awarded  Popular Question
Oct
2
comment connect: Network is unreachable
So, never mind, I was apparently lying. If I do: wlan off, eth off, eth on, the default gateway is set correctly. So you are right, it was a matter of two interfaces with a default gateway. But I am sure this has never caused a problem before. Somehow I have taken the interfaces out of the control of the OS (I have been playing with VMs and bridges lately), so it seems now the OS is not able to set the default gateway properly by itself, and needs some help.
Oct
2
comment connect: Network is unreachable
Sure, but I am turning off wlan and restarting eth0 (I do this because the wlan in my workplace is sometimes flaky, and I need a reliable connection to my servers for long-running tasks). This has worked fine for me in the past, but somehow now it is broken.
Oct
2
comment connect: Network is unreachable
Thanks, I have just got to that conclusion with the help of @faker. I wonder why I do not get a default gateway (eth0 is just setup with ` iface eth0 inet dhcp`)
Oct
2
comment connect: Network is unreachable
@faker: yes, I already realized about it comparing with the settings with wlan active. See my updated question.
Oct
2
revised connect: Network is unreachable
added 890 characters in body
Oct
2
comment connect: Network is unreachable
@faker: bingo! IPv4 is indeed broken: wget -4 just fails. I was not seeing the forest because of so many trees :). Thanks. Now I wonder if that is an issue with my interface configuration (I have indeed been playing with it recently) or if it has something to do with the network itself.
Oct
2
comment connect: Network is unreachable
That is a very good hint. I'll check that in a minute but ... how do you know that wget used IP6 from the output I pasted?
Oct
2
asked connect: Network is unreachable
Oct
1
accepted Access pty login prompt in VM
Oct
1
comment Access pty login prompt in VM
thanks!!! Defining the ttyS0 in the guest worked. Now I will be able to tweak the VM, even if network access is not working! If I could upvote you 10 times, I would do it!
Oct
1
comment Access pty login prompt in VM
For me hitting enter (repeteadly!) did not have any effect. My VM is not up now. but I will try this later and report. Thanks for the hint!
Oct
1
comment Access pty login prompt in VM
This looks promising. I will check if my guest has the tty defined (I thought this was standard). What worries me is this sentence: "note that username input works even if the login promt is not shown". If I do not get visual output, this is not really gonna help me: no use running commands on the VM if I get not output.
Oct
1
comment Access pty login prompt in VM
Not really. My VM is working fine, I do not use virt-manager, I do not want to use virt-manager. I just want to connect to the login prompt of the VM. Surely virt-manager is not a dependency of libvirt, correct? You can run VMs without virt-manager, with full functionality, correct? So, now that we have that cleared: how do I configure the VM to be able to connect with virsh console (or any other virsh command?) to the login prompt? I do not know it, and it seems you do not know it neither. Which is fine. Maybe somebody else knows it?
Oct
1
comment Access pty login prompt in VM
@MichaelHampton: As I said, no GUI: ImportError: No module named libvirt. virt-manager is broken in Ubuntu (actually, Mint)
Oct
1
comment Access pty login prompt in VM
Thanks, but no GUI.
Oct
1
asked Access pty login prompt in VM