292 reputation
16
bio website
location
age
visits member for 3 years, 3 months
seen Nov 10 at 23:40

Nov
10
answered Strange character in the password field of OSX Terminal
Aug
14
awarded  Revival
Mar
29
awarded  Nice Answer
Mar
17
awarded  Critic
Mar
17
comment SSH garbling characters in vim/nano on remote server
Note that the “VT-100 keypad behavior” preference is entirely unrelated to this Q&A and has no effect on the outcome.
Sep
24
revised SSH garbling characters in vim/nano on remote server
added 126 characters in body
Sep
21
awarded  Yearling
Jun
27
comment Terminal.app does not support alt/meta/command-key modifiers such as meta-backspace
The Emacs setting only applies if you're using a native Emacs application, not Emacs via a terminal. This question is about using programs via Terminal, so it's only necessary/useful to change the Terminal preference.
Jun
27
comment Terminal.app does not support alt/meta/command-key modifiers such as meta-backspace
@Chealion wrote, “ If you change the preference you have to make a new window in order for it to take effect - it doesn't apply to open windows.” That is incorrect. Most changes to the Settings preferences take effect in all the existing terminals using that settings profile. Exceptions include a couple of the items in “Advanced” that set environment variables—they can't be altered by Terminal once the shell is started.
Mar
11
revised OS X WiFi settings via terminal?
Corrected the spelling of the “OS X" operating system (and capitalization of WiFi)
Mar
10
suggested suggested edit on OS X WiFi settings via terminal?
Nov
9
answered SSH garbling characters in vim/nano on remote server
Sep
3
awarded  Supporter
Aug
29
comment OS X Terminal lines don't go into scrollback
Another possibility is that a program left the terminal with a "scroll region". There are codes to tell the terminal to only scroll a sub-range of lines when scrolling. Programs use this to display status lines, for example, that don't scroll off the screen. If the scroll region doesn't include the top line, the text won't scroll into the scrollback log. Again, however, you said you tried a Hard Reset, which should clear that, too.
Aug
29
revised OS X Terminal lines don't go into scrollback
Added information about using tput to switch screens.
Aug
29
comment OS X Terminal lines don't go into scrollback
If you're back in the shell after running a "full screen" program, yes, that's a possibility, although most popular programs, like the ones I listed, are reliable about cleaning up after themselves. If a "full screen" program crashes it might leave the terminal on the alternate screen. However, you said you tried Shell > Send Hard Reset, which includes switching back to the main screen. If it happens again, you could try using this command to switch back: tput rmcup
Aug
29
awarded  Teacher
Aug
28
awarded  Editor
Aug
28
revised OS X Terminal lines don't go into scrollback
Added information on using terminfo to suppress the alternate screen.
Aug
28
answered OS X Terminal lines don't go into scrollback