101 reputation
1
bio website appleseedhq.net
location
age
visits member for 3 years, 2 months
seen Aug 5 at 16:05

Jul
18
awarded  Supporter
Oct
14
comment Ruby/Passenger stops working after update to OpenSSL
Yes, I did. Specifically comment #24 describes well the actions I took and matches my current setup: ruby 1.8.7 (2008-05-31 patchlevel 0) [i686-linux], gem 1.8.10, rubytree 0.8.1, RAILS_GEM_VERSION = '2.3.12' in config/environment.rb, removed vendor/rails/. But for some reason rubytree (or maybe another package?) is not found. Current status of the app: redmine.appleseedhq.net. Many thanks for your help quanta!
Oct
14
comment Ruby/Passenger stops working after update to OpenSSL
I found part of the culprit: redmine comes with some bits of rails and some gems in the vendor/ directory; after removing the rails bits and changing config/environment.rb to use rails 2.3.12 (I had to update from 2.3.11 to 2.3.12 to fix the actionmailer error) I'm now getting a page of deprecation warnings and the the following error: Missing these required gems: rubytree >= 0 You're running: ruby 1.8.7.0 at /usr/local/bin/ruby rubygems 1.8.10 at /usr/local/lib/ruby/gems/1.8, /root/.gem/ruby/1.8 Run 'rake gems:install' to install the missing gems.
Oct
14
comment Ruby/Passenger stops working after update to OpenSSL
So, I went the second way. Alongside my own version of Ruby (1.8.7 in /usr/local/bin/), I installed gem and then all the gems required by Redmine (rails, rake, rubygems-update, etc.). This went a long way in reviving my Redmine app, unfortunately I'm now stuck in "gem hell" as I can't seem to find the right combo of gem versions. Right now (for Redmine 1.1.2) I'm using rails 2.3.11, actionmailer 2.3.11, rake 1.1.2 and rubygems-update 1.5.2. This ought to be a supported combo, but I'm invariably getting the following error: undefined method 'name' for "actionmailer":String. Any idea?
Oct
13
asked Ruby/Passenger stops working after update to OpenSSL