5

I run Apache HTTPD 2.2 on my FreeBSD 7.2 webserver. I have enabled the httpready and dataready in my /boot/loader.conf, like this:

accf_http_load="YES"
accf_data_load="YES"

That works great when the server is started, but whenever I restart (via apachectl graceful or apachectl restart), I get a salvo like this in my /var/log/httpd-error.log:

[Thu Oct 08 13:32:53 2009] [warn] (22)Invalid argument: Failed to enable the 'httpready' Accept Filter
[Thu Oct 08 13:32:53 2009] [warn] (22)Invalid argument: Failed to enable the 'dataready' Accept Filter
[Thu Oct 08 13:32:53 2009] [warn] (22)Invalid argument: Failed to enable the 'httpready' Accept Filter
[Thu Oct 08 13:32:53 2009] [warn] (22)Invalid argument: Failed to enable the 'dataready' Accept Filter
[Thu Oct 08 13:32:53 2009] [warn] (22)Invalid argument: Failed to enable the 'httpready' Accept Filter
[Thu Oct 08 13:32:53 2009] [warn] (22)Invalid argument: Failed to enable the 'httpready' Accept Filter

There' is a bug for this on ASF bugzilla, but that doesn't look like it's going anywhere soon, so in the meantime, I'm looking to find out if this is really a problem (does the httpready filter still work despite the warnings?), and if it is, is there a workaround?

2
  • Note that this is similar to serverfault.com/questions/68120/… but has more specifics. Thus the new question.
    – mikl
    Oct 8, 2009 at 11:53
  • Did you check via kldstat to make sure something really crazy didn't happen to the module? Also did you try restarting Apache from the rc script (/usr/local/etc/rc.d/apache22 restart)?
    – Chris S
    Jan 17, 2012 at 1:13

3 Answers 3

2

I believe it's one of two things. Either Apache doesn't close the previous connection before opening the new listening socket (or it might even recycle the old) or the Kernel associates filter use with a PID instead of a socket (which would be weird at best). Definitely something not right but I'm not sure if it's in Apache or the Kernel. The problem still exists in 9.0 and 2.2.20.

Since nobody seems to have bothered with this in 2 years and it's easily worked around by using the rc script instead of apachectl, I'm not going to hunt it down (sorry).

1
  • Thanks for the insight. I switched to nginx a year ago, so it does not really matter to me either :)
    – mikl
    Jan 18, 2012 at 19:54
0

You don't want to use the httpready filter on FreeBSD at this time anyway. I recommend disabling it entirely.

1
  • 3
    On what do you base this recommendation?
    – voretaq7
    Sep 13, 2011 at 16:16
-2

Just open shell prompt and type the following command to load accf_http under FreeBSD :

# kldload accf_http Restart apache:

# /usr/local/etc/rc.d/apache22 restart Update /boot/loader.conf file

Type the following command so that driver get loaded at the time of booting system:

# echo 'accf_http_load="YES"' >> /boot/loader.conf

http://www.cyberciti.biz/faq/failed-to-enable-the-httpready-accept-filter/

1
  • 1
    If you had actually read my question, you'd find that I already have the mentioned line in /boot/loader.conf.
    – mikl
    Oct 11, 2011 at 14:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .