4 replaced http://serverfault.com/ with https://serverfault.com/
source | link

So, it looks like this is a duplicate of This questionThis question, but I don't feel that poster got a sufficient answer, so I would still like to know why the local time is being preferred over the server. Also, as per one of the answers below, I tried to use the prefer keyword on the server line of the config and restart, but that does not seem to have had an effect.

Also, thisthis looks like another duplicate without a good answer.

So, it looks like this is a duplicate of This question, but I don't feel that poster got a sufficient answer, so I would still like to know why the local time is being preferred over the server. Also, as per one of the answers below, I tried to use the prefer keyword on the server line of the config and restart, but that does not seem to have had an effect.

Also, this looks like another duplicate without a good answer.

So, it looks like this is a duplicate of This question, but I don't feel that poster got a sufficient answer, so I would still like to know why the local time is being preferred over the server. Also, as per one of the answers below, I tried to use the prefer keyword on the server line of the config and restart, but that does not seem to have had an effect.

Also, this looks like another duplicate without a good answer.

3 added 1368 characters in body
source | link
 

AlsoEDIT -

So, it looks like this is a duplicate of This question, but I don't feel that poster got a sufficient answer, so I would still like to know why the local time is being preferred over the server. Also, as per one of the answers below, I tried to use the prefer keyword on the server line of the config and restart, but that does not seem to have had an effect.

If I do remove all of the "local" lines in casethe config as the answer to the other question suggest, what will happen if the server is unreachable? Does NTP die or does it means somethingjust keep trying?


IMPORTANT EDIT --

Ok, normally, 10.130.33.201 (The "server") has no access to anyone:the internet, and does not have a GPS time source to use. The important part is that all the devices on the system have the same time as the server, regardless of how correct that time actually is.

So, just to see what would happen, I added one of the NTP pool servers to the config file of the server so it would get time from there rather than getting time from local. It now correctly gets time from the NTP time server.

After I did that, the clients now sync with the server rather than prefering LOCAL(0)

ntpdc -cntpq loopinfo-p
offset:         remote      0.000000 s
frequency:    refid      st t 0.000when ppm
poll adjust:          30
watchdog timer:reach   delay   offset 47 s

jitter
ntpdc -c kerninfo==============================================================================
pll*10.130.33.201 offset:  38.229.71.1      3 u  0 s
pll58 frequency:  64  377    0.000 ppm
maximum error:   216  715621.   01.018928 s001
estimated error:      LOCAL(0 s
status:  )        .LOCL.     0001  pll
pll time constant: 10 l  6
precision: 18   64  377    0.000  1e-06 s
frequency tolerance:0.000  500 ppm0.001

 

EDITNEW QUESTION -

So When my server is using local (original example that was given), it looksseems like thisthe clients are saying, "Oh, 10.130.33.201 is a duplicate of This questionusing LOCAL(0). Hmm, but I don't feel that poster gotalso have a sufficient answer, so I would still like to knowLOCAL(0) server why the local time is being preferred over-- I'll just use that directly rather than getting the serversame information via 10. Also, as per one of130.33.201".

Is that the answers belowcase? Are they trying to go "directly to the source" which is incorrectly LOCAL(0)? I need my server to get time from LOCAL(0), and I triedneed the clients to useget time from the prefer keyword onserver. Right now removing the "local" server line offrom the client config and restartfiles is the only option, but that does not seemI would like to have had an effectunderstand why this is happening, and if at all possible, avoid changing their configs (config change will be a lot of work because of our environment...).

If I do remove all of the "local" lines in the config as the answer to the other question suggestAlso, what will happen if the server is unreachable? Does NTP die or does it just keep trying?this looks like another duplicate without a good answer.

Also, in case it means something to anyone:

ntpdc -c loopinfo
offset:               0.000000 s
frequency:            0.000 ppm
poll adjust:          30
watchdog timer:       47 s


ntpdc -c kerninfo
pll offset:           0 s
pll frequency:        0.000 ppm
maximum error:        0.018928 s
estimated error:      0 s
status:               0001  pll
pll time constant:    6
precision:            1e-06 s
frequency tolerance:  500 ppm

 

EDIT -

So, it looks like this is a duplicate of This question, but I don't feel that poster got a sufficient answer, so I would still like to know why the local time is being preferred over the server. Also, as per one of the answers below, I tried to use the prefer keyword on the server line of the config and restart, but that does not seem to have had an effect.

If I do remove all of the "local" lines in the config as the answer to the other question suggest, what will happen if the server is unreachable? Does NTP die or does it just keep trying?

 

EDIT -

So, it looks like this is a duplicate of This question, but I don't feel that poster got a sufficient answer, so I would still like to know why the local time is being preferred over the server. Also, as per one of the answers below, I tried to use the prefer keyword on the server line of the config and restart, but that does not seem to have had an effect.

If I do remove all of the "local" lines in the config as the answer to the other question suggest, what will happen if the server is unreachable? Does NTP die or does it just keep trying?


IMPORTANT EDIT --

Ok, normally, 10.130.33.201 (The "server") has no access to the internet, and does not have a GPS time source to use. The important part is that all the devices on the system have the same time as the server, regardless of how correct that time actually is.

So, just to see what would happen, I added one of the NTP pool servers to the config file of the server so it would get time from there rather than getting time from local. It now correctly gets time from the NTP time server.

After I did that, the clients now sync with the server rather than prefering LOCAL(0)

 ntpq -p
     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
*10.130.33.201   38.229.71.1      3 u   58   64  377    0.216  715621.   1.001
 LOCAL(0)        .LOCL.          10 l   18   64  377    0.000    0.000   0.001

NEW QUESTION - When my server is using local (original example that was given), it seems like the clients are saying, "Oh, 10.130.33.201 is using LOCAL(0). Hmm, I also have a LOCAL(0) server -- I'll just use that directly rather than getting the same information via 10.130.33.201".

Is that the case? Are they trying to go "directly to the source" which is incorrectly LOCAL(0)? I need my server to get time from LOCAL(0), and I need the clients to get time from the server. Right now removing the "local" server from the client config files is the only option, but I would like to understand why this is happening, and if at all possible, avoid changing their configs (config change will be a lot of work because of our environment...).

Also, this looks like another duplicate without a good answer.

2 added 676 characters in body
source | link

EDIT -

So, it looks like this is a duplicate of This question, but I don't feel that poster got a sufficient answer, so I would still like to know why the local time is being preferred over the server. Also, as per one of the answers below, I tried to use the prefer keyword on the server line of the config and restart, but that does not seem to have had an effect.

If I do remove all of the "local" lines in the config as the answer to the other question suggest, what will happen if the server is unreachable? Does NTP die or does it just keep trying?


EDIT -

So, it looks like this is a duplicate of This question, but I don't feel that poster got a sufficient answer, so I would still like to know why the local time is being preferred over the server. Also, as per one of the answers below, I tried to use the prefer keyword on the server line of the config and restart, but that does not seem to have had an effect.

If I do remove all of the "local" lines in the config as the answer to the other question suggest, what will happen if the server is unreachable? Does NTP die or does it just keep trying?

1
source | link