2 replaced http://serverfault.com/ with https://serverfault.com/
source | link

Let me quote the other excellent answerexcellent answer by James SneeringerJames Sneeringer from the other question:mail loops back to myself | postfixmail loops back to myself | postfix

This happens when domain.com has an MX record (or, in the absence of an MX, an A record) that points to your Postfix server, but your Postfix server is not configured to accept mail for that domain.

From the quote above, basically there are two conditions that can make this error happen

  1. Postfix receive email with its recipient address wasn't listed as local domains, so postfix should relay those email
  2. Postfix routing engine was decide that an email should be relayed to same postfix instance

To fix this error we must fix one of possible cause above.

  • First problem can happen if you forgot to introduce the domain to postfix after pointing it via MX record. We need to insert the domain as the local one so postfix shouldn't relayed the email. The domain can be listed in mydestination, virtual_mailbox_domains or virtual_alias_domains.
  • Second problem can happen if you already remove the domain from postfix local domain but forgot to change the MX record (or A record if MX wasn't available). In this case postfix will relay the email into itself and complain with above error. The solution is change A or MX record. Or perhaps postfix was configured to use /etc/hosts, then you should checks this file too.
  • The second problem can also happen if you override mail routing via DNS mechanism with postfix internal routing. Common parameter to configuring mail static routing was transport_maps. Check if you put the address on those maps and delete if it exists.

From the description of your problem, looks like the culprit here was postfix transport_maps parameter. Your DNS record was fine and you states that the domain should be handled somewhere besides postfix. Removing this entry

gencom.us smtp:206.225.87.101

and run postmap the_problematic_file should solves your problem.

Let me quote the other excellent answer by James Sneeringer from the other question:mail loops back to myself | postfix

This happens when domain.com has an MX record (or, in the absence of an MX, an A record) that points to your Postfix server, but your Postfix server is not configured to accept mail for that domain.

From the quote above, basically there are two conditions that can make this error happen

  1. Postfix receive email with its recipient address wasn't listed as local domains, so postfix should relay those email
  2. Postfix routing engine was decide that an email should be relayed to same postfix instance

To fix this error we must fix one of possible cause above.

  • First problem can happen if you forgot to introduce the domain to postfix after pointing it via MX record. We need to insert the domain as the local one so postfix shouldn't relayed the email. The domain can be listed in mydestination, virtual_mailbox_domains or virtual_alias_domains.
  • Second problem can happen if you already remove the domain from postfix local domain but forgot to change the MX record (or A record if MX wasn't available). In this case postfix will relay the email into itself and complain with above error. The solution is change A or MX record. Or perhaps postfix was configured to use /etc/hosts, then you should checks this file too.
  • The second problem can also happen if you override mail routing via DNS mechanism with postfix internal routing. Common parameter to configuring mail static routing was transport_maps. Check if you put the address on those maps and delete if it exists.

From the description of your problem, looks like the culprit here was postfix transport_maps parameter. Your DNS record was fine and you states that the domain should be handled somewhere besides postfix. Removing this entry

gencom.us smtp:206.225.87.101

and run postmap the_problematic_file should solves your problem.

Let me quote the other excellent answer by James Sneeringer from the other question:mail loops back to myself | postfix

This happens when domain.com has an MX record (or, in the absence of an MX, an A record) that points to your Postfix server, but your Postfix server is not configured to accept mail for that domain.

From the quote above, basically there are two conditions that can make this error happen

  1. Postfix receive email with its recipient address wasn't listed as local domains, so postfix should relay those email
  2. Postfix routing engine was decide that an email should be relayed to same postfix instance

To fix this error we must fix one of possible cause above.

  • First problem can happen if you forgot to introduce the domain to postfix after pointing it via MX record. We need to insert the domain as the local one so postfix shouldn't relayed the email. The domain can be listed in mydestination, virtual_mailbox_domains or virtual_alias_domains.
  • Second problem can happen if you already remove the domain from postfix local domain but forgot to change the MX record (or A record if MX wasn't available). In this case postfix will relay the email into itself and complain with above error. The solution is change A or MX record. Or perhaps postfix was configured to use /etc/hosts, then you should checks this file too.
  • The second problem can also happen if you override mail routing via DNS mechanism with postfix internal routing. Common parameter to configuring mail static routing was transport_maps. Check if you put the address on those maps and delete if it exists.

From the description of your problem, looks like the culprit here was postfix transport_maps parameter. Your DNS record was fine and you states that the domain should be handled somewhere besides postfix. Removing this entry

gencom.us smtp:206.225.87.101

and run postmap the_problematic_file should solves your problem.

1
source | link

Let me quote the other excellent answer by James Sneeringer from the other question:mail loops back to myself | postfix

This happens when domain.com has an MX record (or, in the absence of an MX, an A record) that points to your Postfix server, but your Postfix server is not configured to accept mail for that domain.

From the quote above, basically there are two conditions that can make this error happen

  1. Postfix receive email with its recipient address wasn't listed as local domains, so postfix should relay those email
  2. Postfix routing engine was decide that an email should be relayed to same postfix instance

To fix this error we must fix one of possible cause above.

  • First problem can happen if you forgot to introduce the domain to postfix after pointing it via MX record. We need to insert the domain as the local one so postfix shouldn't relayed the email. The domain can be listed in mydestination, virtual_mailbox_domains or virtual_alias_domains.
  • Second problem can happen if you already remove the domain from postfix local domain but forgot to change the MX record (or A record if MX wasn't available). In this case postfix will relay the email into itself and complain with above error. The solution is change A or MX record. Or perhaps postfix was configured to use /etc/hosts, then you should checks this file too.
  • The second problem can also happen if you override mail routing via DNS mechanism with postfix internal routing. Common parameter to configuring mail static routing was transport_maps. Check if you put the address on those maps and delete if it exists.

From the description of your problem, looks like the culprit here was postfix transport_maps parameter. Your DNS record was fine and you states that the domain should be handled somewhere besides postfix. Removing this entry

gencom.us smtp:206.225.87.101

and run postmap the_problematic_file should solves your problem.