1

We would like to backup the AIX 5.3 IntelliStation at our company. Unfortunately it does not have a tapedrive nor a DVD-Writer. It only has a DVD-ROM drive.

The idea is to mount a directory via NFS and to create an ISO image there. Afterwards We would use a different machine to create a bootable DVD from the ISO image.

How can this be done? I have tried the mkdvd command from a smitty terminal, but it seems that mkdvd does not accept a filename, e.g. /nfsmount/aixbackup/system-image.iso.

Any help on this is very appreciated!

0

2 Answers 2

1

Mkdvd can be used for this.
It will take the rootvg (or a backup made with mksysb) and will write it on the specified device.

To create a bootable dvd, you can simply use the following:

mkdvd -d /dev/cd1

You should have a look at mkdvd, mksysb and savevg documentation before doing anything nasty on your server..

1

meanwhile I found out how to create a bootable DVD .iso image.

Instructions:

unset LC_ALL

# note: I have unmounted /home before creating the iso image. Otherwise I would need multiple DVDs

# note: I have mounted an NFS directory below /volumes/aixsav
extdir=/volumes/aixsav

# create some needed subdirectories
for i in mksysb_target tmp iso mkcd; do
       test -d $extdir/$i || mkdir $extdir/$i || exit 1
done

# finally: create the .iso image.
/usr/sbin/mkdvd -M $extdir/mksysb_target -C $extdir/tmp -I $extdir/iso -S

This needs some time. But after all I had my image in the iso subdirectory. I went to another machine and burned the image to a DVD (under linux).

For testing I have shut down the AIX machine and replaced the existing harddisk with a another empty one. Then I booted up and followed the onscreen instruction for restoring from DVD.

Everything went fine. Even the Usernames/Passwords, Hostname, IP-Address everything was like on the original harddrive!

a final note: be patient! creating the Image and booting from the DVD will need some time. Just lay back and wait ...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .