0

Ok so my setup is, I have 2 vlans currently routing through fa0 on cable internet with DHCP. I want to be able to plug dsl, also dhcp, into fa1 and have it work as an auto failover if fa0 goes down. I am just not sure of how to proceed. All the examples I have seen online work witout NATing in place, so if someone could point me in the right direction, I would much appreciate it.

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$I9I.$nqNqNaH..3CJ6xtB7FSVR0
enable password 7 106D5E4853441F1C1445
!
no aaa new-model
!
!
dot11 syslog
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 10.0.0.1 10.0.0.10
ip dhcp excluded-address 10.10.0.1 10.10.0.2
!
ip dhcp pool Lan1DHCP
    network 10.0.0.0 255.255.255.0
    default-router 10.0.0.1 
    dns-server 8.8.8.8 
!
ip dhcp pool FamDHCP
    network 10.10.0.0 255.255.0.0
    default-router 10.10.0.1 
    dns-server 8.8.8.8 
!
!
!
multilink bundle-name authenticated
!
!
! 
!
archive
log config
hidekeys
!
!
!
!     
interface FastEthernet0
  ip address dhcp
  ip nat outside
  ip virtual-reassembly
  duplex auto
  speed auto
!         
interface FastEthernet1
  ip address dhcp
  ip nat outside
  ip virtual-reassembly
  duplex auto
  speed auto
!         
interface FastEthernet2
   switchport access vlan 10
   !         
interface FastEthernet3
   switchport access vlan 10
!         
interface FastEthernet4
   switchport access vlan 10
!         
interface FastEthernet5
   switchport access vlan 10
!         
interface FastEthernet6
!         
interface FastEthernet7
!         
interface FastEthernet8
!         
interface FastEthernet9
   switchport access vlan 20
!         
interface Vlan1
   no ip address
!
interface Vlan10
   ip address 10.0.0.1 255.255.255.0
   ip nat inside
   ip virtual-reassembly
!         
interface Vlan20
   ip address 10.10.0.1 255.255.0.0
   ip nat inside
   ip virtual-reassembly
!         
interface Async1
   no ip address
   encapsulation slip
!         
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 dhcp
!         
!         
no ip http server
no ip http secure-server
ip nat inside source list 101 interface FastEthernet0 overload
ip nat inside source list 102 interface FastEthernet0 overload
ip nat inside source static tcp 10.0.0.200 80 interface FastEthernet0 80
ip nat inside source static tcp 10.0.0.200 443 interface FastEthernet0 443
!         
access-list 101 permit ip 10.0.0.0 0.0.0.255 any
access-list 101 permit tcp any host 0.0.0.0 eq www
access-list 101 permit tcp any host 0.0.0.0 eq 443
access-list 102 permit ip 10.10.0.0 0.0.255.255 any
!
!
end

1 Answer 1

0

Here are two great examples. I have referenced both documents in the past to configuration this very failover scenario.

NAT failover with DUAL ISP on a router Configuration Example

ISP Failover with Default Routes using IP SLA Tracking

EXAMPLE CONFIGURATION:

interface GigabitEthernet0/0/1
 description PRIMARY LINK TO ISP 1
 ip address 10.0.12.1 255.255.255.252
 ip nat outside
 negotiation auto
!
interface GigabitEthernet0/0/0
 description BACKUP LINK TO ISP 2
 ip address 10.0.13.1 255.255.255.252
 ip nat outside
 negotiation auto
!
interface GigabitEthernet0/0/2
 description TOWARDS CUSTOMER LAN
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 negotiation auto
!
!
ip access-list extended 101
 permit ip 192.168.1.0 0.0.0.255 any
!
track 8 ip sla 1 reachability
!
ip sla 1
 icmp-echo 10.0.12.2 source-ip 10.0.12.1
ip sla schedule 1 life forever start-time now
!
ip route 0.0.0.0 0.0.0.0 10.0.12.2 track 8
ip route 0.0.0.0 0.0.0.0 10.0.13.2 10
!
route-map NAT_ISP2 permit 10
 match ip address 101
 match interface GigabitEthernet0/0/0
!
route-map NAT_ISP1 permit 10
 match ip address 101
 match interface GigabitEthernet0/0/1
!
ip nat inside source route-map NAT_ISP1 interface GigabitEthernet0/0/1 overload
ip nat inside source route-map NAT_ISP2 interface GigabitEthernet0/0/0 overload
1
  • Thank you. Have been busy so haven't had a chance to get back around to this yet. Apr 30, 2017 at 23:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .