0

https://www.rawgymsdublin.com resolves to http://https//www.rawgyms.com/

syntax in the .htaccess file is:

Redirect 301 / https://www.rawgyms.com/

I just updated the name servers to this host on Friday so it is only recently swapped. Can anyone tell me is the syntax wrong, or is there a better method to 301 redirect?

edit: added image of network traffic in the browser

network traffic in the browser

  • The redirect directive itself looks OK providing this .htaccess file is for the rawgymsdublin.com domain only? Is that all you have in the .htaccess file? Check the network traffic in the browser to confirm what redirect(s) are happening. "resolves to" - presumably you mean "redirects to"? The DNS A records for this host are returning different results on each request? – MrWhite Jan 27 at 12:12
  • The A records are in amazon AWS, maybe that is causing an issue, but I thought if the name servers were updated that it would bypass AWS A records? – Paul Murphy Jan 27 at 12:13
  • I'm getting a X-Cache: Hit from cloudfront header when I try that URL. Is it possible that the redirect is configured in cloudfront and never reaches your server? – Gerald Schneider Jan 27 at 12:28
  • Seems to be sporadic DNS issues? The redirect appeared to work once (correctly) for me - after some delay - then it failed to connect entirely? Maybe you're currently working on the issue? – MrWhite Jan 27 at 12:51
  • @MrWhite I also have this in the file: AddHandler php73-script .php .php5 also, yes I disabled CloudFront, might take 15 mins to complete – Paul Murphy Jan 27 at 12:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.