0

I'm trying to configure an Azure Internal Load Balancer, I have created in Basic SKU and Standard SKU. I want to use it with a SQL Server VM (TCP 1433), but is not working, when I test it with tcping to the front-end IP and port 1433 does'n respond. I have check the health probe, originally I created to test to 1433 TCP port, but latter change it to TCP 3389, also TCP 445, but it does'nt work eather.

I have tested the load balancer from a VM on the same subnet that the Load balancer is on, and also from my onpremise network (via VPN).

I have checked the NSG and everything looks good, I have created an incoming rule to allow "Azure Load Balancers" access to my Vnet, and also an Outgoing Rule to allow any traffic from my Vnet to "Azure Load Balancer", but it does'n work.

Also, I disabled Windows Firewall on the backend server.

Is there a way to check the result from the Health probe? Is there anything else I can check?

Regards.

2
  • UPDATE: The Load Balancer was working, the problem was not with it. I checked installing Wireshark on the server and reviewing the connections to the server using the Front end IP as destination, and found that the traffic was getting without problems to the VM. It seems that the SQL Server is not responding to those connections. – Alberto Medina Mar 3 '20 at 23:33
  • Are you trying to build an AlwaysOn cluster? If yes, there are additional configuration steps to take. If not, what are you doing with a load balancer in front of SQL Server?!? – Massimo Dec 15 '20 at 21:29
0

Sounds that you have configured everything that is needed but always good to verify from Microsoft tutorials

You have opened your NSG for your load balancer probes but have you also created an NSG rule to allow traffic from the client that initiate traffic against you VM?

Standard load balancer have a probe metric

Also here is some other troubleshooting steps you can check

0

I think you have enabled floating IP on the rules, disable that and see the results.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.