0

I have a virtual machine Win 10, and I can connect to it via RDP (Remote Desktop Protocol) from my local laptop. Now I want to establish a VPN (L2TP/IPSec) on the remote Win 10 to a third host, because I cannot connect to the third host from my local laptop. However, the connected RDP session to the Win10 failed after the VPN is established on the Win10. Actually, I also can visit the virtual machine (VM) Win10 through the control panel of the VM provider in the browser, so I can confirm that the VPN is indeed connected, but I cannot connect to it via RDP. And if I disconnect the VPN, the RDP connection would be OK again.

I have searched several related questions, such as Prevent SSH connection lost after logging into VPN on server machine, but it is for SSH and OpenVPN on Linux, not RDP and L2TP/IPSec for me.

Hope someone can help me.

0

This is due to the security settings on the RDP for the remote machine. It sounds like you've got it set to a more strict policy where it requires the connections to be on the LAN.

On the Windows 10 machine goto 1. Control Panel > System and Security > System 2. Select Remote Settings 3. Check "Allow Remote Connections to this computer" 4. Uncheck the "Allow Connections only from computers running Remote Desktop with network Level Auth."

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.