Asking this on both serverfault and superuser.

When attempting to network boot RHEL 5.4 on an old ia64 machine I get the following error :

alt text

So I've basically followed the tutorial here : http://www-uxsup.csx.cam.ac.uk/pub/doc/suse/sles9/adminguide-sles9/ch04s03.html

DHCPD,TFTPD etc are already setup and working with standard x86 PXE clients.

I've unpacked the boot.img file into /tftpboot/ia64/ and passed the path to the elilo.efi file via DHCP with the filename ""; option.

Changing this filename generates a PXE file not found error (see below). So I assume that PXE has found the file... alt text

The only thing wrong I can find in the logs is :

Jan 6 19:49:31 dhcphost in.tftpd[31379]: tftp: client does not accept options

Any ideas? I'm sure I hit a problem like this a few years ago but I can't remember the fix :)

Thanks in advance!

  • I'll be rewording the question and adding more info in the morning. For now the brain dump above will have to do ;)
    – lyarwood
    Jan 6, 2010 at 22:19
  • If someone with more rep could update the links I'd be extremely grateful :)
    – lyarwood
    Jan 7, 2010 at 10:21
  • I've not tried anything with EFI yet, but 'tftp: client does not accept options' is a non-fatal warning. Don't worry about that at all. EFI is poorly supported by PXE utilities at this point, so that may be the source of your issues.
    – devicenull
    Feb 11, 2012 at 1:36

3 Answers 3


I messed around with DHCP/BootP/PXE a while ago. The easiest thing I can recommend you do is to set up a virtual machine and install TftpD as you can configure it to be verbose and use it to diagnose problems.

From that screen, it looks like as it says, it simply cannot find the file - try messing around with forward slashes in the name (at the start), and keeping it simple, for example try just elilo.efi in the path and place the file in the root tftp directory.

When it comes to diagnosing things like this, you really want to take it to basics and get complicated when you know it is working.

  • Why? It's trivial to update the xinetd file for tftp to enable verbose logging (edit /etc/xinet.d/tftp to add '-v' to the server_args line, then service xinetd restart). TFTP is also a pretty trivial protocol, so a tcpdump trace would be simple to follow. Installing a Windows VM with another TFTP server just to get verbose output? That's crazy.
    – devicenull
    Feb 11, 2012 at 1:38

Have you tried the 'network boot' rather than the INET option?

  • Yes, the INET option points at eth0, I justed edited the name as I kept hitting the eth1 option. Yes before you ask I've plugged in eth1 and tried using it ;)
    – lyarwood
    Jan 7, 2010 at 9:49
  • ok, thanks for that, is your PXE server on the same subnet as this box and if not have you tried that?
    – Chopper3
    Jan 7, 2010 at 10:07
  • Yes it is, updated the summary (formatted version here : superuser.com/questions/92295/efi-pxe-network-boot-error). PXE is working fine with X86 PXE clients.
    – lyarwood
    Jan 7, 2010 at 10:25

Have a look of gpxe, I'd had some really good success with that!!!!! It's awesome.

  • gPXE doesn't support EFI.
    – devicenull
    Feb 11, 2012 at 1:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.