1

I was setting up my first workspace in Eclipse and Weblogic 10.3.6 server,

I started the Weblogic server and I am getting the below error in Server's Tab of eclipse.

   Oracle WebLogic server 11gR1 (10.3.6) base_domain [Stopped, Error connecting to WebLogic domain] 

When I hopped on to the console tab of eclipse It says that the server is started in the Running Mode and also I was able to access the console login

 <Feb 5, 2020 5:04:46 PM PST> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to RUNNING> 
 <Feb 5, 2020 5:04:46 PM PST> <Notice> <WebLogicServer> <BEA-000360> <Server started in RUNNING mode>



 http://localhost:7001/console/login/LoginForm.jsp

I tried restart my machine and start the server using startWebLogic Windows command

I got the following Error message,

JAVA Memory arguments: -Xms1024m -Xmx2048m -XX:CompileThreshold=8000 -XX:PermSize=1024m  -XX:MaxPermSize=2048m
.
WLS Start Mode=Development
.
***************************************************
*  To start WebLogic Server, use a username and   *
*  password assigned to an admin-level user.  For *
*  server administration, use the WebLogic Server *
*  console at http:\\hostname:port\console        *
***************************************************
starting weblogic with Java version:
java version "1.7.0_79"
Java(TM) SE Runtime Environment (build 1.7.0_79-b15)
<Feb 5, 2020 5:40:45 PM CST> <Info> <WebLogicServer> <BEA-000377> <Starting WebLogic Server with Java 
 HotSpot(TM) 64-Bit Server VM Version 24.79-b02 from Oracle Corporation>
 <Feb 5, 2020 5:40:55 PM CST> <Info> <Management> <BEA-141281> <unable to get file lock, will retry ...>
 <Feb 5, 2020 5:41:05 PM CST> <Info> <Management> <BEA-141281> <unable to get file lock, will retry ...>

I tried almost all the solutions available on serverfault and stackoverflow.

Any advice?

1
  • if no other process is running for the same server, then you have to remove the file that is causing the lock <unable to get file lock, will retry ...> Mar 9, 2020 at 0:24

3 Answers 3

0

I had the same error. My problem was I was running an Nginx listening in port 7003. So, that was causing a port conflict with Weblogic. My solution was to remove that reverse proxy from Nginx. You could also check if you have any process listening on 7003 with the commands:

netstat -aon | findstr 7003

taskkill /f /pid

I hope this help anyone who get the same trouble.

0

Even if it says that the server is Stopped, it's not actually true, your server is running but Eclipse does not detect it (this is the real problem you are facing). So the "unable to get file lock" is because of that. If you kill your server you will be able to start it again from the command line with the command startWebLogic.cmd.

As I said, the problem is that Eclipse cannot detect/connect to it, so you are not able to debug your applications within Eclipse.

I was facing the same problem, and after some investigation I found that the fault was with the jvm version used by Eclipse. If Eclipse starts with jvm8 it works fine, but unfortunately Eclipse versions > 2020-06 require jdk11, so you will have to use at most eclipse-2020-06. You can check the jvm version used by Eclipse in file eclipse.ini in eclipse's install directory and change it if it is greater than 8 (the jvm used is found after the line with -vm).

The problem is that with jdk11 and up, some library required to connect to JMX is missing (either because is not bundled with the jvm, or it is repackaged/refactored in some other library). By looking at the error logs I found in my case that the class org.omg.CORBA_2_3.portable.ObjectImpl is missing so Eclipse is raising a ClassNotFoundException; probably adding this library to the classpath of the jvm would work either, but I haven't tried it.

TL;DR

To use Oracle Weblogic Tools plugin you can install it in Eclipse up to version 2020-06 and start it with a jvm version not greater than 8.

-1
  1. Check whether you are running another server.
  2. Check out these links:
1
  • Welcome on ServerFault. Please consider explaining the content of your links, because relying on external resources is bad practice.. they could be altered or removed, and your answer will be unuseful. You should explain your solution and links should be just an integration instead. Good read
    – Marco
    Feb 20, 2020 at 14:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .