I'm experimenting with an installation of TFS 2010 Beta 2 on a virtual machine under VirtualBox running Windows Server 2008. When I've got the server in a workgroup, I can connect to it from Visual Studio just fine, as long as I provide credentials for a local user on the server machine when prompted by the "Connect to Team Foundation Server" dialog. The desktop I'm running Visual Studio on is joined to a domain.

However, when I join the server to the domain, I can no longer connect to it from Visual Studio. I get a pretty generic error message: "TF31002 - Unable to connect to team foundation server". It gives me several different possible problems, including an incorrect address or an incorrect username and password.

I've already added the domain Windows identity with which I'm logged on the the desktop to the TFS Admins group on the server, so I don't think it's a username/password problem. I've also tried putting the literal IP address of the server in the dialog address box instead of the machine name, but still no dice. I made sure that network discovery was enabled on the server, too, and can navigate to "\\webserver2008" in Windows Explorer without any problems. Shouldn't be a firewall problem, since the TFS install creates the appropriate exceptions in Windows Firewall. It's all a bit confusing, since it seems to work when the server is in a workgroup.

Note: I'm a dev, not an admin, so there are many subtleties of server administration with which I'm not familiar. Please make no assumptions about what I may or may not have tried; what may be obvious to you may have never occurred to me. Thanks in advance!

2 Answers 2


It looks like you installed TFS in the VM while NOT joined to the domain. I don't believe Microsoft supports joining a TFS server to AD after TFS has been installed. You would need to completely reinstall TFS 2010. If you join AD after the installation I believe the TFS services will work, but still only under the local machine context; you wouldn't be able to use AD accounts with it.

Someone correct me if I'm mistaken on this...

  • That makes sense. A bit inconvenient, but oh well. Thanks! Feb 15, 2010 at 3:54

I've just gone through a similar set of circumstances. I think you'll find that the virtual machine needs to be able to "see" the domain server at least once when you try to connect to the TFS server on the virtual machine.

If you're always connected to the network with the domain server, then this is probably not your problem, but if like me you're trying to connect from a laptop that has VS on it & the virtual machine with TFS installed on it, but the laptop is not currently connected to the domain's network, it will fail.

Once I connected the TFS virtual machine to the domain network it worked. I haven't tried it yet, but I'm hoping that having authenticated once in this way, that it will continue to authenticate me, just like a disconnected laptop will do.

I hope this help, took me half a day to figure out why it wasn't working for me. But it's working now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .