0

I have a plone zinstance set up through Apache Proxy on OS X Server 10.5. The server is set up with a single vhost on port 80, with Proxy & Proxypass directives to the Plone zinstance:

        ProxyPass / http://localhost:8080/VirtualHostBase/http/server:80/Plone/VirtualHostRoot/
        ProxyPassReverse / http://localhost:8080/VirtualHostBase/http/server:80/Plone/VirtualHostRoot/

However, I have some static HTML and PHP content that I want to display in an iframe via the plone site. I'm thinking I'll need to set up another vhost on a different port, then just specify the port # inline?

  • I've gotten it to where I can see the iframe in plone. I'm serving an additional vhost on port 8888 available to localhost only. I can see the first page, but if I try to click one of the links inside that should take me to a php page, it just sits there. – churnd Jan 7 '10 at 12:50
1

Here is what I have: anything in /images, /styles, /scripts does not go to Plone.

ProxyRequests Off
ProxyTimeout 600
ProxyPreserveHost On

ProxyPass /images !
ProxyPass /styles !
ProxyPass /scripts !

ProxyPass / http://localhost:8080/

ProxyPassReverse / http://localhost:8080/

RewriteEngine On
RewriteCond %{REQUEST_URI} !^/(images|scripts|styles|projects)/(.*)

RewriteRule ^/(.*) http://localhost:8080/VirtualHostBase/http/%{SERVER_NAME}:80/Plone/VirtualHostRoot/$1 [L,P]

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.