0

I'm smashing my head against a wall. I can't seem to get my guest VMs to use a different VLAN than my host machine.
I have a 2 node Hyper V cluster(2016). Each node has 2 10Gig NICs in a Team. This team is assigned to a vSwitch and set as External with Allow Management OS. I then have "Enable virtual LAN identification for management operating system" checked and VLAN 99 set. Virtual switch settings for Host

Within the settings of one of my guests I have the same virtual switch selected and I've checked "Enable Virtual LAN Identification" and set the value to 199.Virtual NIC of guest VM

When I check the MAC Address table of my switch the guest is showing up in VLAN 99 instead of the desired VLAN 199.

My switchport is configured as a trunk and set to allow vlan 99 and vlan 199:

interface port-channel33
 description "VIP-StW1 onboard1"
 no shutdown
 switchport mode trunk
 switchport access vlan 1
 switchport trunk allowed vlan 99,199
 mtu 9216
 vlt-port-channel 33
 spanning-tree port type edge

I've verified that there isn't any VLANs set on the physical NICs themselves and that VLAN is enabled on them. Any ideas what I could be missing?

0

Sometimes you just need to go to sleep and you'll wake up with the answer. I fixed my own problem. I had checked the VLAN tagging on the individual physical NICs but not on the actual Team Interface in the Microsoft NIC Teaming configurator. I guess when it was created it was tagged as VLAN 99 and not set to Default. Setting is to Default has fixed my problem. Guests are able to use any VLAN that I dictate within HyperV settings.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.