0

I have IIS published web application that I can connect with my local ip and port. Like 192.168.1.99:81

After adding inbounding rules, router DMZ and port forwarding, closing both windows and router firewall, I can not access to web application with my public ip and port.

I am trying to reach it like https://publicIp:81

When I check to port it says, port is closed and when I try to reach it gives connection time put.

What am I missing here?

  • Hi Matt. I didn't have default config for 80, after installing IIS, should I check anything else in Windows firewall? – MEO Feb 14 at 18:46
  • Eep. It struck me as a stupid comment so I deleted. What else... Have you looked at localhost:81 from the server itself? (Not quite what you asked, just asking a basic question) – Matt Murphy Feb 14 at 19:02
  • 1
    Yeah I did it, it works. I also checked with my phone on same lan. I am binding with myIP:81 and hostname:81 – MEO Feb 14 at 19:05
  • Apologies, you kind of covered that already in your question. Sorry. You've managed to isolate the issue to the router, I think. Someone might be able to chime in with if you give specifics about the router. (?) – Matt Murphy Feb 14 at 19:09
  • I actually figured out event I close router firewall, add my local IP to DMZ and add rule for port forwarding, port is not open. Do you think it would cause this? – MEO Feb 14 at 19:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.