Newly installed Exchange 2010 box (technically, a partially installed box, as this error is preventing me from completing the install).

When I launch EMC or the Management Powershell, I get this error:

VERBOSE: Connecting to myserver.mydomain.internal
Processing data from remote server failed with the following error message: 
The user "mydomain\administrator" isn't assigned to any management roles. 
For more information, see the about_Remote_Troubleshooting Help topic.
Failed to connect to any Exchange Server in the current site.

Thing is..

The logged in administrator account (confirmed using 'whoami') is a member of the following groups:

Delegated Setup
Discovery Management
Domain Admins
Domain Users
Enterprise Admins
Exchange Organization Administrators
GPO Creator Owners
Organization Management
Schema Admins
Server Management

Any ideas? how can I get past this?

4 Answers 4


@Richard, chances are a different user account was used for the schema preparations during the pre-install tasks as to those that were used to install Exchange.

Ensure your account is a member of the Organization Management group, and see if the error is resolved for you.


  • 1
    The Organization Management group can be found in Active Directory Users and Computers under the "Microsoft Exchange Security Groups" folder in the domain.
    – Wolfgang
    Aug 11, 2017 at 23:19
  • This worked for me. I was a domain admin and still not working. Adding to the Organization management group worked instantly :-) Thanks
    – jcrawfor74
    Jul 26, 2018 at 11:16
  • Thanks! I added Domain Admins to this group
    – Xebozone
    Jul 21, 2020 at 1:37

I found the solution, courtesy of David Strome at Microsoft.



When our Exchange 2010 server was installed we used a particular domain account.

For administration we use different User accounts.

Each user that will be administering the exchange server must be a member of "Organization Management" this is all you should need to ensure the user is a member of.

I wanted to claify this as the simplest fix also posted by David George



I was also facing the same issue. but now its working by login with Administrator Privilege account Simply right click on Exchange management console run as different user my server operation system is 2012...........use your administrator account for exchange login....

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .